Bump the version of multi_json that Sidekiq is dependent on. #559

Merged
merged 1 commit into from Dec 3, 2012

Conversation

3 participants
Collaborator

brandonhilkert commented Dec 3, 2012

No description provided.

@mperham mperham added a commit that referenced this pull request Dec 3, 2012

@mperham mperham Merge pull request #559 from mperham/multijson-update
Bump the version of multi_json that Sidekiq is dependent on.
0fd7e97

@mperham mperham merged commit 0fd7e97 into master Dec 3, 2012

1 check passed

default The Travis build passed
Details
Contributor

nateberkopec commented Dec 14, 2012

Unfortunately, it looks like this is incompatible with Rails 3.1.x.

Bundler could not find compatible versions for gem "multi_json":
  In Gemfile:
    sidekiq (>= 0) ruby depends on
      multi_json (>= 1.3.0) ruby

    rails (= 3.1.8) ruby depends on
      multi_json (1.2.0)

https://github.com/rails/rails/blob/3-1-stable/activesupport/activesupport.gemspec#L21

Owner

mperham commented Dec 14, 2012

I was afraid of that. @brandonhilkert Can you revert?

Owner

mperham commented Dec 14, 2012

Once Rails 4 is out, we'll release a new major version of Sidekiq that only supports 4 and 3.2. Until then, 3.1 needs to work.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment