Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Subtitles not being rendered after EOF is reached and rewinding (with keep-open) #3770

Closed
wrielxc opened this issue Nov 6, 2016 · 0 comments

Comments

Projects
None yet
1 participant
@wrielxc
Copy link

commented Nov 6, 2016

mpv version and platform

mpv git-7c9f326; Windows 7 64-bit; GTX 1060

Reproduction steps

Play any video to the end with keep-open in mpv.conf.
Use the mouse or the arrow keys to step back to an earlier point in time.

Expected behavior

Subtitles should be rendered properly if demuxer-mkv-subtitle-preroll=yes is in mpv.conf.
Even if that line is not in mpv.conf, after playing the video for a bit later subtitles will be rendered properly.

Actual behavior

With git-7c9f326, stepping back to an earlier point in time does not render subtitles at all, even when deselecting and reselecting subtitles with either the OSC or keybinds. Sometimes, the last line of the sub file is rendered and stays on the screen the entirety of the time.
This was not a problem with git-90b968a or earlier (fairly sure it was 1ff6d8a that broke it).

Log files

http://sprunge.us/gMWN

Sample files

Happens on any video.

@wm4 wm4 closed this in c4d6fcb Nov 18, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.