New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Noisy audio like broken audio #4582

Closed
shinchiro opened this Issue Jul 8, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@shinchiro
Contributor

shinchiro commented Jul 8, 2017

mpv version and platform

8c0162e - Win10-x64

Reproduction steps

Play audio

Expected behavior

Normal audio

Actual behavior

Noticed noisy audio like broken radio in beginning of file.

Log file

8c0162e log
log.txt

69289ae log (works correctly)
log.txt

I guess it should played as float, not stereo u8

Sample files

https://0x0.st/GsT.opus

@kevmitch

This comment has been minimized.

Member

kevmitch commented Jul 8, 2017

I think I've got a fix for this, but I'm not in windows at the moment to test. I'll post it shortly.

kevmitch added a commit to kevmitch/mpv that referenced this issue Jul 8, 2017

ao_wasapi: try correct initial format
The loop to select the native wasapi_format for the incoming audio was
not breaking correctly when it found the most desirable format. It
therefore executed completely leaving the least desirable format (u8) as
the choice.

fixes mpv-player#4582
@shinchiro

This comment has been minimized.

Contributor

shinchiro commented Jul 9, 2017

Yeah, that PR fixed it

@kevmitch kevmitch closed this in 2514e54 Jul 9, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment