New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Since v0.24, mpv fails to detect blu-ray subtitle language #4611

Closed
macdavis opened this Issue Jul 16, 2017 · 6 comments

Comments

Projects
None yet
3 participants
@macdavis

macdavis commented Jul 16, 2017

mpv version and platform

mpv (v0.24) and later, MacOS 10.12.5 (16F73)

Reproduction steps

Download this sample MVC 3D ISO Sample #2 with 3D Subtitles and play it.

Actual behavior

In 0.24, subtitle language can't be detected while in 0.23, it can be.

Log file

Make a log file made with -v or --log-file=output.txt, paste it to
0.24.log
0.23.log

Sample files

MVC 3D ISO Sample #2 with 3D Subtitles

@j605

This comment has been minimized.

Contributor

j605 commented Jul 16, 2017

You should at least upgrade to the latest release before reporting issues. Anyways I was not able to play this file and ffprobe gave me the following error:

[mpegts @ 0x560572e402e0] Could not detect TS packet size, defaulting to non-FEC/DVHS
[mpegts @ 0x560572e402e0] max resync size reached, could not find sync byte
    Last message repeated 13 times
[mpegts @ 0x560572e402e0] changing packet size to 192
[mpegts @ 0x560572e402e0] Stream #0: not enough frames to estimate rate; consider increasing probesize
[mpegts @ 0x560572e402e0] start time for stream 0 is not set in estimate_timings_from_pts
[mpegts @ 0x560572e402e0] max resync size reached, could not find sync byte
    Last message repeated 21 times

This might explain why I am not able to play it.

edit:ffplay works.

@macdavis

This comment has been minimized.

macdavis commented Jul 16, 2017

This problem still occurs in the latest git version. Sorry if I didn't make myself clear.
git(8e20ef4).log

@wm4

This comment has been minimized.

Contributor

wm4 commented Jul 16, 2017

Do they use different libbluray versions?

@macdavis

This comment has been minimized.

macdavis commented Jul 16, 2017

@wm4
All mpv tests are under the same version of libbluray.
With libbluray 0.9.0: mpv 0.23 - ok, mpv 0.24 - not working, mpv git(8e20ef4) - not working;
With libbluray 1.0.1: mpv 0.23 - ok, mpv 0.24 - not working, mpv git(8e20ef4) - not working.

@wm4

This comment has been minimized.

Contributor

wm4 commented Jul 16, 2017

Can you bisect mpv git?

@macdavis

This comment has been minimized.

macdavis commented Jul 16, 2017

@wm4
I tried to locate it manually. It seems this bug was introduced in commit fb9a32977d6abf4c83a92d993af58e393819c062

Commit e13a62fc346867450cd41d02cffbdaf477a3fec4 is the last version that works fine.

@wm4 wm4 closed this in c1dcf74 Jul 16, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment