New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Vapoursynth filter - missing P10 formats #4720

Closed
chainikdn opened this Issue Aug 6, 2017 · 0 comments

Comments

Projects
None yet
1 participant
@chainikdn

chainikdn commented Aug 6, 2017

mpv version and platform

0.26

Reproduction steps

import vapoursynth as vs
core = vs.get_core()

clip = video_in.resize.Bicubic(format=vs.YUV420P10)
clip.set_output()

Expected behavior

It used to work in 0.25:

[ 0.515][v][vd] Decoder format: 1280x720 [0:1] yuv420p10 auto/auto/auto/limited CL=mpeg2/4/h264
[ 0.552][v][vf] Video filter chain:
[ 0.552][v][vf] [in] 1280x720 yuv420p10 bt.709/bt.709/bt.1886/limited CL=mpeg2/4/h264
[ 0.552][v][vf] [vapoursynth] "vapoursynth.00" 1280x720 yuv420p10 bt.709/bt.709/bt.1886/limited CL=mpeg2/4/h264
[ 0.552][v][vf] [out] 1280x720 yuv420p10 bt.709/bt.709/bt.1886/limited CL=mpeg2/4/h264
[ 0.566][i][cplayer] VO: [opengl] 1280x720 yuv420p10

Actual behavior after 300f6a3

[ 0.393][v][vd] Decoder format: 1280x720 [0:1] yuv420p10 auto/auto/auto/limited CL=mpeg2/4/h264
[ 0.398][i][vf] Using conversion filter.
[ 0.398][v][scale] Setting option 'warn' = 'no' (flags = 0)
[ 0.402][v][ffmpeg] SwScaler: reducing / aligning filtersize 1 -> 4
[ 0.402][v][ffmpeg] SwScaler: reducing / aligning filtersize 1 -> 4
[ 0.402][v][ffmpeg] SwScaler: reducing / aligning filtersize 1 -> 1
[ 0.402][v][ffmpeg] SwScaler: reducing / aligning filtersize 1 -> 1
[ 0.402][v][ffmpeg] swscaler: bicubic scaler, from yuv420p10le to yuv420p16le using MMXEXT
[ 0.402][v][ffmpeg] swscaler: 1280x720 -> 1280x720
[ 0.402][v][ffmpeg] swscaler: using unscaled yuv420p10le -> yuv420p16le special converter
[ 0.417][f][vapoursynth] Unsupported output format.
[ 0.421][e][vf] Image formats incompatible or invalid.
[ 0.421][w][vf] Video filter chain:
[ 0.422][w][vf] [in] 1280x720 yuv420p10 bt.709/bt.709/bt.1886/limited SP=1.000000 CL=mpeg2/4/h264
[ 0.422][w][vf] [scale] 1280x720 yuv420p16 bt.709/bt.709/bt.1886/limited SP=1.000000 CL=mpeg2/4/h264 [a]
[ 0.422][w][vf] [vapoursynth] "vapoursynth.00" ??? <---
[ 0.422][w][vf] [out] ???
[ 0.422][f][cplayer] Cannot initialize video filters.

... while P10 still works w/o Vapoursynth:

[ 0.479][v][vd] Decoder format: 1280x720 [0:1] yuv420p10 auto/auto/auto/limited CL=mpeg2/4/h264
[ 0.480][v][vf] Video filter chain:
[ 0.480][v][vf] [in] 1280x720 yuv420p10 bt.709/bt.709/bt.1886/limited SP=1.000000 CL=mpeg2/4/h264
[ 0.480][v][vf] [out] 1280x720 yuv420p10 bt.709/bt.709/bt.1886/limited SP=1.000000 CL=mpeg2/4/h264
[ 0.481][i][cplayer] VO: [opengl] 1280x720 yuv420p10

@wm4 wm4 closed this in bbb5769 Aug 7, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment