Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Bump version to 2.1devel

  • Loading branch information...
commit 5300ecb4e8f8ce9ec200b91c7273dae1947e431c 1 parent 6a8c434
@mpx authored
View
6 build-packages.sh
@@ -5,7 +5,7 @@
# Build packages. Use current checked out version, or a specific tag/commit.
# Files requiring a version bump
-VERSION_FILES="lua-cjson-2.0devel-1.rockspec lua-cjson.spec lua_cjson.c manual.txt runtests.sh tests/test.lua"
+VERSION_FILES="lua-cjson-2.1devel-1.rockspec lua-cjson.spec lua_cjson.c manual.txt runtests.sh tests/test.lua"
[ "$1" ] && BRANCH="$1" || BRANCH="`git describe --match '[1-3].[0-9]*'`"
VERSION="`git describe --match '[1-3].[0-9]*' $BRANCH`"
@@ -25,8 +25,8 @@ git archive --prefix="$PREFIX/" "$BRANCH" | tar xf - -C "$BUILDROOT"
cd "$BUILDROOT"
cd "$PREFIX"
-rename 2.0devel "$VERSION" $VERSION_FILES
-perl -pi -e "s/\\b2.0devel\\b/$VERSION/g" ${VERSION_FILES/2.0devel/$VERSION};
+rename 2.1devel "$VERSION" $VERSION_FILES
+perl -pi -e "s/\\b2.1devel\\b/$VERSION/g" ${VERSION_FILES/2.1devel/$VERSION};
cd ..
make -C "$PREFIX" doc
View
4 lua-cjson-2.0devel-1.rockspec → lua-cjson-2.1devel-1.rockspec
@@ -1,8 +1,8 @@
package = "lua-cjson"
-version = "2.0devel-1"
+version = "2.1devel-1"
source = {
- url = "http://www.kyne.com.au/~mark/software/download/lua-cjson-2.0devel.zip",
+ url = "http://www.kyne.com.au/~mark/software/download/lua-cjson-2.1devel.zip",
}
description = {
View
2  lua-cjson.spec
@@ -3,7 +3,7 @@
%define luadatadir %{_datadir}/lua/%{luaver}
Name: lua-cjson
-Version: 2.0devel
+Version: 2.1devel
Release: 1%{?dist}
Summary: A fast JSON encoding/parsing module for Lua
View
2  lua_cjson.c
@@ -51,7 +51,7 @@
#endif
#ifndef CJSON_VERSION
-#define CJSON_VERSION "2.0devel"
+#define CJSON_VERSION "2.1devel"
#endif
/* Workaround for Solaris platforms missing isinf() */
View
8 manual.txt
@@ -1,4 +1,4 @@
-= Lua CJSON 2.0devel Manual =
+= Lua CJSON 2.1devel Manual =
Mark Pulford <mark@kyne.com.au>
:revdate: January 22, 2012
@@ -102,7 +102,7 @@ has been installed.
Build and install the module via RPM:
[source,sh]
-rpmbuild -tb lua-cjson-2.0devel.tar.gz
+rpmbuild -tb lua-cjson-2.1devel.tar.gz
rpm -Uvh $LUA_CJSON_RPM
@@ -117,7 +117,7 @@ First, extract the Lua CJSON source package.
Next, install the module:
[source,sh]
-cd lua-cjson-2.0devel
+cd lua-cjson-2.1devel
luarocks make
[NOTE]
@@ -590,7 +590,7 @@ The name of the Lua CJSON module (+"cjson"+).
_VERSION
~~~~~~~~
-The version number of the Lua CJSON module (+"2.0devel"+).
+The version number of the Lua CJSON module (+"2.1devel"+).
null
View
2  runtests.sh
@@ -1,7 +1,7 @@
#!/bin/sh
PLATFORM="`uname -s`"
-[ "$1" ] && VERSION="$1" || VERSION="2.0devel"
+[ "$1" ] && VERSION="$1" || VERSION="2.1devel"
set -e
View
2  tests/test.lua
@@ -93,7 +93,7 @@ local cjson_tests = {
-- Test API variables
{ "Check module name, version",
function () return json._NAME, json._VERSION end, { },
- true, { "cjson", "2.0devel" } },
+ true, { "cjson", "2.1devel" } },
-- Test decoding simple types
{ "Decode string",
Please sign in to comment.
Something went wrong with that request. Please try again.