Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

move dev dependencies to gemspec (except carrierwave, not working fro…

…m gemspec for some reason)
  • Loading branch information...
commit 49bfadc28e0c776eefe8a2971e47868787a4007f 1 parent 28b0f4d
@mrbrdo authored
Showing with 21 additions and 23 deletions.
  1. +1 −12 Gemfile
  2. +11 −11 Gemfile.lock
  3. +9 −0 has_moderated.gemspec
View
13 Gemfile
@@ -10,15 +10,4 @@ gemspec
# Git. Remember to move these dependencies to your gemspec before releasing
# your gem to rubygems.org.
-# To use debugger
-# gem 'ruby-debug'
-gem 'rspec'
-gem 'rspec-rails'
-gem 'rails3-generators'
-gem 'carrierwave'
-gem 'ruby-debug'
-gem 'rmagick'
-
-gem 'spork'
-gem 'guard-spork'
-gem 'guard-rspec'
+gem 'carrierwave'
View
22 Gemfile.lock
@@ -88,23 +88,23 @@ GEM
rdoc (~> 3.4)
thor (~> 0.14.6)
rake (0.9.2.2)
- rbx-require-relative (0.0.5)
+ rbx-require-relative (0.0.9)
rdoc (3.12)
json (~> 1.4)
rmagick (2.13.1)
- rspec (2.8.0)
- rspec-core (~> 2.8.0)
- rspec-expectations (~> 2.8.0)
- rspec-mocks (~> 2.8.0)
- rspec-core (2.8.0)
- rspec-expectations (2.8.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.8.0)
- rspec-rails (2.8.1)
+ rspec (2.10.0)
+ rspec-core (~> 2.10.0)
+ rspec-expectations (~> 2.10.0)
+ rspec-mocks (~> 2.10.0)
+ rspec-core (2.10.0)
+ rspec-expectations (2.10.0)
+ diff-lcs (~> 1.1.3)
+ rspec-mocks (2.10.1)
+ rspec-rails (2.10.1)
actionpack (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
- rspec (~> 2.8.0)
+ rspec (~> 2.10.0)
ruby-debug (0.10.4)
columnize (>= 0.1)
ruby-debug-base (~> 0.10.4.0)
View
9 has_moderated.gemspec
@@ -19,4 +19,13 @@ Gem::Specification.new do |s|
s.add_dependency "rails", ">=3.0.0"
s.add_development_dependency "sqlite3"
+ s.add_development_dependency 'rspec'
+ s.add_development_dependency 'rspec-rails'
+ s.add_development_dependency 'rails3-generators'
+ s.add_development_dependency 'ruby-debug'
+ s.add_development_dependency 'rmagick'
+
+ s.add_development_dependency 'spork'
+ s.add_development_dependency 'guard-spork'
+ s.add_development_dependency 'guard-rspec'
end
Please sign in to comment.
Something went wrong with that request. Please try again.