Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

added database.yml template for local install, + instructions in READ…

…ME. Gemfile.lock referred to a version of devise that had been yanked; now points to 1.5.3
  • Loading branch information...
commit f9e0f12875913d001726cf51b70f08fd1f5a7f3b 1 parent ed7d76a
Philip (flip) Kromer authored
View
2  Gemfile
@@ -16,7 +16,7 @@ gem 'friendly_id', "~> 3.3.0" # Human readable URLs
gem 'validates_existence', "~> 0.5" # Validation of associations
gem 'chronic', "~> 0.6.1" # Time parsing
gem 'will_paginate', "~> 3.0.0" # Pagination of long lists
-gem 'devise', "~> 1.1" # User management
+gem 'devise', "~> 1.4" # User management
# gem 'hassle', :git => 'git://github.com/koppen/hassle.git'
gem 'dalli'
View
127 Gemfile.lock
@@ -2,12 +2,12 @@ GEM
remote: http://rubygems.org/
specs:
abstract (1.0.0)
- actionmailer (3.0.10)
- actionpack (= 3.0.10)
+ actionmailer (3.0.11)
+ actionpack (= 3.0.11)
mail (~> 2.2.19)
- actionpack (3.0.10)
- activemodel (= 3.0.10)
- activesupport (= 3.0.10)
+ actionpack (3.0.11)
+ activemodel (= 3.0.11)
+ activesupport (= 3.0.11)
builder (~> 2.1.2)
erubis (~> 2.6.6)
i18n (~> 0.5.0)
@@ -15,113 +15,110 @@ GEM
rack-mount (~> 0.6.14)
rack-test (~> 0.5.7)
tzinfo (~> 0.3.23)
- activemodel (3.0.10)
- activesupport (= 3.0.10)
+ activemodel (3.0.11)
+ activesupport (= 3.0.11)
builder (~> 2.1.2)
i18n (~> 0.5.0)
- activerecord (3.0.10)
- activemodel (= 3.0.10)
- activesupport (= 3.0.10)
+ activerecord (3.0.11)
+ activemodel (= 3.0.11)
+ activesupport (= 3.0.11)
arel (~> 2.0.10)
tzinfo (~> 0.3.23)
- activeresource (3.0.10)
- activemodel (= 3.0.10)
- activesupport (= 3.0.10)
- activesupport (3.0.10)
+ activeresource (3.0.11)
+ activemodel (= 3.0.11)
+ activesupport (= 3.0.11)
+ activesupport (3.0.11)
annotate (2.4.0)
arel (2.0.10)
- awesome_print (0.4.0)
- babosa (0.3.5)
- bcrypt-ruby (3.0.0)
+ awesome_print (1.0.2)
+ babosa (0.3.6)
+ bcrypt-ruby (3.0.1)
builder (2.1.2)
- chronic (0.6.3)
- chunky_png (1.2.1)
- coderay (0.9.8)
- compass (0.11.5)
+ chronic (0.6.6)
+ chunky_png (1.2.5)
+ coderay (1.0.5)
+ compass (0.11.7)
chunky_png (~> 1.2)
fssm (>= 0.2.7)
sass (~> 3.1)
compass-960-plugin (0.10.4)
compass (>= 0.10.0)
- daemons (1.1.4)
- dalli (1.1.1)
- devise (1.4.4)
+ daemons (1.1.6)
+ dalli (1.1.4)
+ devise (1.5.3)
bcrypt-ruby (~> 3.0)
orm_adapter (~> 0.0.3)
- warden (~> 1.0.3)
+ warden (~> 1.1)
erubis (2.6.6)
abstract (>= 1.0.0)
eventmachine (0.12.10)
- friendly_id (3.3.0.1)
+ friendly_id (3.3.2.0)
babosa (~> 0.3.0)
- fssm (0.2.7)
- haml (3.1.2)
+ fssm (0.2.8.1)
+ haml (3.1.4)
haml-rails (0.3.4)
actionpack (~> 3.0)
activesupport (~> 3.0)
haml (~> 3.0)
railties (~> 3.0)
- hirb (0.5.0)
+ hirb (0.6.0)
html5-boilerplate (1.0.0)
compass (>= 0.11.1)
i18n (0.5.0)
+ json (1.6.5)
mail (2.2.19)
activesupport (>= 2.3.6)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- method_source (0.6.0)
- ruby_parser (>= 2.0.5)
- mime-types (1.16)
+ method_source (0.7.0)
+ mime-types (1.17.2)
nifty-generators (0.4.6)
- orm_adapter (0.0.5)
- polyglot (0.3.2)
- pry (0.9.3)
- coderay (>= 0.9.8)
- method_source (>= 0.6.0)
- ruby_parser (>= 2.0.5)
- slop (~> 1.9.0)
- rack (1.2.3)
+ orm_adapter (0.0.6)
+ polyglot (0.3.3)
+ pry (0.9.8)
+ coderay (~> 1.0.5)
+ method_source (~> 0.7)
+ slop (>= 2.4.3, < 3)
+ rack (1.2.5)
rack-mount (0.6.14)
rack (>= 1.0.0)
rack-test (0.5.7)
rack (>= 1.0)
- rails (3.0.10)
- actionmailer (= 3.0.10)
- actionpack (= 3.0.10)
- activerecord (= 3.0.10)
- activeresource (= 3.0.10)
- activesupport (= 3.0.10)
+ rails (3.0.11)
+ actionmailer (= 3.0.11)
+ actionpack (= 3.0.11)
+ activerecord (= 3.0.11)
+ activeresource (= 3.0.11)
+ activesupport (= 3.0.11)
bundler (~> 1.0)
- railties (= 3.0.10)
- railties (3.0.10)
- actionpack (= 3.0.10)
- activesupport (= 3.0.10)
+ railties (= 3.0.11)
+ railties (3.0.11)
+ actionpack (= 3.0.11)
+ activesupport (= 3.0.11)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.4)
- rake (0.9.2)
- rdoc (3.9.4)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
rest-client (1.6.7)
mime-types (>= 1.16)
- ruby_parser (2.2.0)
- sexp_processor (~> 3.0)
- sass (3.1.7)
+ sass (3.1.12)
sequel (3.20.0)
- sexp_processor (3.0.6)
sinatra (1.0)
rack (>= 1.0)
- slop (1.9.1)
- sqlite3 (1.3.4)
+ slop (2.4.3)
+ sqlite3 (1.3.5)
sqlite3-ruby (1.3.3)
sqlite3 (>= 1.3.3)
taps (0.3.23)
rack (>= 1.0.1)
- rest-client (< 1.7.0, >= 1.4.0)
+ rest-client (>= 1.4.0, < 1.7.0)
sequel (~> 3.20.0)
sinatra (~> 1.0.0)
sqlite3-ruby (~> 1.2)
- thin (1.2.11)
+ thin (1.3.1)
daemons (>= 1.0.9)
eventmachine (>= 0.12.6)
rack (>= 1.0.0)
@@ -129,11 +126,11 @@ GEM
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.29)
- validates_existence (0.7.0)
- warden (1.0.5)
+ tzinfo (0.3.31)
+ validates_existence (0.7.1)
+ warden (1.1.0)
rack (>= 1.0)
- will_paginate (3.0.0)
+ will_paginate (3.0.2)
PLATFORMS
ruby
@@ -145,7 +142,7 @@ DEPENDENCIES
compass (~> 0.11.5)
compass-960-plugin (~> 0.10.4)
dalli
- devise (~> 1.1)
+ devise (~> 1.4)
friendly_id (~> 3.3.0)
haml (~> 3.0)
haml-rails (~> 0.3.4)
View
3  README.textile
@@ -25,8 +25,9 @@ To run the app
<pre>
cd lunchlady
bundle install
+ cp config/database.yml.example config/database.yml # and edit if desired
rake db:migrate
- rake db:seed # optional, but loads a bunch of restaurants etc. Editdb/seeds.rb and db/seeds/*.tsv to suit
+ rake db:seed # optional: loads a bunch of restaurants so you can play around. Editdb/seeds.rb and db/seeds/*.tsv to suit
rails server
</pre>
View
22 config/database.yml.example
@@ -0,0 +1,22 @@
+# SQLite version 3.x
+# gem install sqlite3-ruby (not necessary on OS X Leopard)
+development:
+ adapter: sqlite3
+ database: db/development.sqlite3
+ pool: 5
+ timeout: 5000
+
+# Warning: The database defined as "test" will be erased and
+# re-generated from your development database when you run "rake".
+# Do not set this db to the same as development or production.
+test:
+ adapter: sqlite3
+ database: db/test.sqlite3
+ pool: 5
+ timeout: 5000
+
+production:
+ adapter: sqlite3
+ database: db/production.sqlite3
+ pool: 5
+ timeout: 5000
Please sign in to comment.
Something went wrong with that request. Please try again.