Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Vundle, the plug-in manager for Vim
Branch: master

This branch is 1 commit ahead, 319 commits behind VundleVim:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
autoload
doc
test
README.md

README.md

About

Vundle is a short cut for Vimbundle and is a Vim plugin manager.

Quick start

  1. Setup Vundle:

    git clone http://github.com/gmarik/vundle.git ~/.vim/bundle/vundle
    
  2. Configure bundles:

    Sample .vimrc:

    set nocompatible               " be iMproved
    filetype off                   " required!
    
    set rtp+=~/.vim/bundle/vundle/
    call vundle#rc()
    
    " let Vundle manage Vundle
    Bundle 'gmarik/vundle'
    
    " My Bundles here:
    "
    " original repos on github
    Bundle 'tpope/vim-fugitive'
    Bundle 'lokaltog/vim-easymotion'
    Bundle 'rstacruz/sparkup', {'rtp': 'vim/'}
    " vim-scripts repos
    Bundle 'L9'
    Bundle 'FuzzyFinder'
    Bundle 'rails.vim'
    " non github repos
    Bundle 'git://git.wincent.com/command-t.git'
    " ...
    
    filetype plugin indent on     " required!
    
  3. Install configured bundles:

    Launch vim, run :BundleInstall.

    Windows users see Vundle for Windows

    Installing requires Git and triggers Git clone for each configured repo to ~/.vim/bundle/.

Why Vundle

Vundle allows to:

Also Vundle:

  • manages runtime path of your installed scripts
  • regenerates helptag atomatically

Docs

see :h vundle vimdoc for more details.

Examples

See gmarik's vimrc for working example.

FAQ

  • Q Why am I asked for username/pass?

    A This is the case of invalid name used with Bundle, which leads to attempt to clone nonexisting repo:

    git clone http://github.com/gmarik/non_existin_repo
    Cloning into non_existin_repo...
    Username: 
    Password: 
    fatal: Authentication failed
    
  • Q My configuration is bundle dependant, so when I try to install plugins for the first time I get errors. How do I fix that?

    A Fix your Chicken or Egg dilemma

Contributors

Thank you!

Inspiration and ideas from

Also

  • Vundle was developed and tested with Vim 7.3 on OSX, Linux and Windows
  • Vundle tries to be as KISS as possible

TODO:

Vundle is a work in progress so any ideas/patches appreciated

  • √ activate newly added bundles on .vimrc reload or after :BundleInstall
  • √ use preview window for search results
  • √ vim documentation
  • √ put vundle to bundles/ too(will fix vundle help)
  • √ tests
  • improve error handling
  • handle dependencies
  • allow specify revision/version?
  • search by description aswell
  • show descrption in search results
  • instead sourcing .vimrc before installation come up with another solution
  • make it rock!
Something went wrong with that request. Please try again.