I looks like there is a new amazon gem #23

Closed
tbbooher opened this Issue Jan 28, 2012 · 6 comments

Comments

Projects
None yet
5 participants

paperclip now requires, aws-sdk -- if you use aws-s3, you get:

LoadError in BlogsController#update

no such file to load -- aws-sdk (You may need to install the aws-sdk gem)
Rails.root: /app

Application Trace | Framework Trace | Full Trace
app/models/blog.rb:40:in `page_tokens='
app/controllers/blogs_controller.rb:56:in `block in update'
app/controllers/blogs_controller.rb:55:in `update'
This error occurred while loading the following files:
aws-sdk

I have the same error , but I add gem 'aws-sdk' to gemfile and bundle install it
I still have this error when I try upload image
I use ruby 1.9.2, rails 3.0.10 and

- aws-s3 (0.6.2)
- aws-sdk (1.3.5)```

JapArt commented Apr 11, 2012

Having the same error in Rails 3.2.2

@JapArt, I remove gem aws-s3 and it work fine. and sometime in local I can not upload, but in host web is work alway fine

deiga commented Mar 11, 2013

#27 Has the pull request to "fix" this

deiga commented Mar 14, 2013

This has been merged to develop, so this issue is done once they release a new version of the gem

Collaborator

tilsammans commented Aug 10, 2016

This has since been released.

tilsammans closed this Aug 10, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment