Skip to content
Permalink
Browse files
Avoid Syntax Error on CRuby v1.8
CRuby v1.8 dose not support named capture
  • Loading branch information
ksss committed Apr 16, 2016
1 parent fa1a17c commit 451523ff02a649009a9e75cdeafd94d686455b2a
Showing 1 changed file with 1 addition and 1 deletion.
@@ -53,7 +53,7 @@ MRuby::Toolchain.new(:visualcpp) do |conf, _params|

if require 'open3'
Open3.popen3 conf.cc.command do |_, _, e, _|
if /Version (?<v>\d{2}\.\d{2}\.\d{5})/ =~ e.gets && v.to_i <= 17
if /Version (\d{2})\.\d{2}\.\d{5}/ =~ e.gets && $1.to_i <= 17
m = "# VS2010/2012 support will be dropped after the next release! #"
h = "#" * m.length
puts h, m, h

0 comments on commit 451523f

Please sign in to comment.