minirake test failed on OSX 10.9.2 #1774

Closed
monaka opened this Issue Mar 1, 2014 · 3 comments

Comments

Projects
None yet
2 participants
Contributor

monaka commented Mar 1, 2014

Hello,

minirake test failed on OSX 10.9.2 (XCode based. Not installed fink and ports and so on.)

$ git clone https://github.com/mruby/mruby.git
Cloning into 'mruby'...
remote: Reusing existing pack: 20413, done.
remote: Counting objects: 83, done.
remote: Compressing objects: 100% (75/75), done.
remote: Total 20496 (delta 26), reused 8 (delta 4)
Receiving objects: 100% (20496/20496), 5.59 MiB | 166.00 KiB/s, done.
Resolving deltas: 100% (12190/12190), done.
Checking connectivity... done
$ cd mruby
$ ./minirake test

(snip)

CC    build/host/test/mrbtest.c -> build/host/test/mrbtest.o
      MRBC test/assert.rb 
CC    build/host/test/assert.c -> build/host/test/assert.o
rake aborted!
No such file or directory - /private/tmp/mruby/build/host/mrbgems/mruby-sprintf/gem_test.c
Contributor

monaka commented Mar 1, 2014

More information. I can build without error by calling ./minirake all test .
Does it cause by dependency breakage?

Contributor

monaka commented Mar 1, 2014

Same error on "Ubuntu 12.04.3 LTS". It may be a machine independent issue.

Owner

matz commented Mar 1, 2014

Try rake all then rake test for work around.
I am still investigating.

matz closed this in 32818bd Mar 1, 2014

@take-cheeze take-cheeze added a commit to take-cheeze/mruby that referenced this issue Mar 1, 2014

@matz @take-cheeze matz + take-cheeze should build "all" before "test"; close #1774 bd1c1b2

@cremno cremno added a commit to cremno/mruby that referenced this issue Mar 4, 2014

@matz @cremno matz + cremno should build "all" before "test"; close #1774 660c5f0

@ghost ghost pushed a commit to iij/mruby that referenced this issue Mar 11, 2014

@matz @tsahara matz + tsahara should build "all" before "test"; close #1774 49db753
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment