Skip to content
ExpressionEngine 2.0 Sublime Text Bundle (with jQuery bundle support)
Find file
Pull request Compare This branch is 6 commits ahead, 1 commit behind wesbaker:master.
Latest commit 7097b95 @mrw Merge pull request #1 from bunchjesse/master
Easy Installation for OSX Users

README.md

ExpressionEngine 2.0 Sublime Text 2 Bundle

ExpressionEngine Sublime Text 2 that also supports the jQuery bundle syntax when inside of <script> tags.

Forked and only slightly modified from Wes Baker's EE 2 TextMate Bundle, which had this note:

A reworked version of Tim Kelty's ExpressionEngine bundle, updated to work with ExpressionEngine 2.0.

Automatic Installation (OSX Only)

Run the following command in Terminal to install the ExpressionEngine bundle. Use of Terminal commands are at your own risk and should only be attempted by those who know what they are doing.

cd /tmp && curl -s https://nodeload.github.com/mrw/ExpressionEngine2-Sublime-Text-Bundle/tarball/master -o expressionengine.tar.gz && tar -xzf expressionengine.tar.gz > /dev/null && mv ./mrw-ExpressionEngine2-Sublime-Text-Bundle* ~/Library/Application\ Support/Sublime\ Text\ 2/Packages/expressionengine && rm -f expressionengine.tar.gz && echo "The ExpressionEngine bundle for Sublime Text 2 is now installed."

Manual Installation

  1. Click the Downloads button at the top right of this page.
  2. Choose the zip file.
  3. Once downloaded, unzip the the zip file.
  4. If you're looking at a folder, rename it to ExpressionEngine. If you're looking at a set of files, create a new folder named ExpressionEngine and put the files in.
  5. Copy the folder to ~/Library/Application Support/Sublime Text 2/Packages/ (make sure this is the Library inside your home folder, not the one in the root of your hard drive)
Something went wrong with that request. Please try again.