Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

COOK-324, update rails attributes

  • Loading branch information...
commit ffba2def564c481a9f8d09f984c2c4591f396157 1 parent da34797
@jtimberman jtimberman authored
View
6 rails/attributes/default.rb
@@ -1,3 +1,3 @@
-set_unless[:rails][:version] = false
-set_unless[:rails][:environment] = "production"
-set_unless[:rails][:max_pool_size] = 4
+default[:rails][:version] = false
+default[:rails][:environment] = "production"
+default[:rails][:max_pool_size] = 4
View
22 rails/metadata.json
@@ -1,5 +1,5 @@
{
- "recommendations": {
+ "providing": {
},
"attributes": {
"rails/version": {
@@ -58,8 +58,7 @@
"display_name": "Rails Environment"
}
},
- "maintainer": "Opscode, Inc.",
- "suggestions": {
+ "replacing": {
},
"dependencies": {
"apache2": [
@@ -69,8 +68,9 @@
]
},
- "maintainer_email": "cookbooks@opscode.com",
- "conflicting": {
+ "groupings": {
+ },
+ "recommendations": {
},
"platforms": {
"debian": [
@@ -90,17 +90,17 @@
]
},
"license": "Apache 2.0",
- "version": "0.9.1",
- "providing": {
+ "version": "0.9.2",
+ "maintainer": "Opscode, Inc.",
+ "suggestions": {
},
"recipes": {
"rails": "Installs rails gems"
},
- "replacing": {
- },
+ "maintainer_email": "cookbooks@opscode.com",
"name": "rails",
- "description": "Installs rails and provides a sample template for use with passenger",
- "groupings": {
+ "conflicting": {
},
+ "description": "Installs rails and provides a sample template for use with passenger",
"long_description": "= DESCRIPTION:\n\nInstalls Rails and contains Rails tuning parameters.\n\n= REQUIREMENTS:\n\n== Platform:\n\nTested on Ubuntu 8.10, should work on other platforms.\n\n== Cookbooks:\n\nOpscode cookbooks, http://github.com/opscode/cookbooks/tree/master:\n\n* ruby \n* apache2 \n* passenger \n\n= ATTRIBUTES: \n\n* rails[:version] - Install the specified version. Default false (installs latest).\n* rails[:environment] - Set Rails environment. Default production.\n\n= USAGE:\n\nThe recommended Rails application deployment method is Passenger and use the Apache2 cookbook's web_app define.\n\n include_recipe \"apache2\"\n include_recipe \"passenger\"\n include_recipe \"rails\"\n\n web_app \"some_rails_app\" do\n docroot \"/srv/some_rails_app/public\"\n template \"some_rails_app.conf.erb\"\n end\n\nWe provide an example rails application vhost config file in this cookbook. Remember, for Passenger, DocumentRoot (docroot) needs 'public'. Per the web_app define, other parameters can be passed arbitrarily and used in the template. \n\n= LICENSE and AUTHOR:\n\nAuthor:: Joshua Timberman (<joshua@opscode.com>)\nCopyright:: 2009, Opscode, Inc\n\nLicensed under the Apache License, Version 2.0 (the \"License\");\nyou may not use this file except in compliance with the License.\nYou may obtain a copy of the License at\n\n http://www.apache.org/licenses/LICENSE-2.0\n\nUnless required by applicable law or agreed to in writing, software\ndistributed under the License is distributed on an \"AS IS\" BASIS,\nWITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.\nSee the License for the specific language governing permissions and\nlimitations under the License.\n"
}
View
2  rails/metadata.rb
@@ -3,7 +3,7 @@
license "Apache 2.0"
description "Installs rails and provides a sample template for use with passenger"
long_description IO.read(File.join(File.dirname(__FILE__), 'README.rdoc'))
-version "0.9.1"
+version "0.9.2"
recipe "rails", "Installs rails gems"
Please sign in to comment.
Something went wrong with that request. Please try again.