New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The Mu editor is not responding. #666

Open
sanchit002sanchit002 opened this Issue Oct 8, 2018 · 8 comments

Comments

Projects
None yet
5 participants
@sanchit002sanchit002
Copy link

sanchit002sanchit002 commented Oct 8, 2018

If you are reporting a bug, we would like to know:

  • What you were trying to do,
  • What steps you took to make this happen,
  • What you expected to happen,
  • What actually happened,
  • Why this difference is problematic (it may not be a bug!),
  • Technical details like the version of Mu you're using, your OS version and
    other aspects of the context in which Mu was running.

Please remember to attach a copy of the full log files for Mu. You can get
the logs by clicking on the cog icon in the bottom right of the editor window.
Click on the logs and use CTRL-A to select all, then CTRL-C to copy and CTRL-V
to paste the contents into the issue.

Thank you for contributing to Mu! :-)

@ntoll

This comment has been minimized.

Copy link
Member

ntoll commented Oct 8, 2018

Hi @sanchit002sanchit002,

Could you please provide some more details -- for example, as described in the description area of the bug report. Once we have more information, we'd love to help.

Thank you!

@sanchit002sanchit002

This comment has been minimized.

Copy link
Author

sanchit002sanchit002 commented Oct 8, 2018

The mu editor is not responding.
Hi sir / mam,
I have installed mu for the first time.
after installing I've chosen python 3 mode, then mu launched and the mu editor is not responding.
I've been waiting for long time, But nothing happened
screenshot 97
.
so When I forced to close the mu, a window pops up the image is attached.
I have python 3.7 already installed and I'm using it with LiClips as my IDE.
I'm running on my machine dell XPS 12 9q23.
Your help will be appreciated.
Thank you.

@ntoll

This comment has been minimized.

Copy link
Member

ntoll commented Oct 8, 2018

Hi @sanchit002sanchit002,

Thank you so much for your information and screen shot.

May I ask how you installed Mu? Was it from the official installer downloaded from the Mu website?

I also notice that you're using JAWS screen reader. Do you have any other screen readers installed which you could try. We've noticed that some readers work better than others when it comes to working with Mu and Python.

Finally, the error message you're seeing is because Python (which is also the language Mu is written in) has encountered a problem, rather than Mu having a problem itself. This more fundamental error suggests to me it's something like an issue with JAWS interacting with the Python language.

Please let me know how you get on with another screen reader.

Perhaps @bmustill-rose might be able to suggest another screen reader..?

@sanchit002sanchit002

This comment has been minimized.

Copy link
Author

sanchit002sanchit002 commented Oct 8, 2018

since mu is not responding how should I attach the logs ?
I am running windows 10 1803 64 bit

@sanchit002sanchit002

This comment has been minimized.

Copy link
Author

sanchit002sanchit002 commented Oct 8, 2018

Yes, I have downloaded from official website.
I also tried with nvda.
But some times nvda is also stops responding when loaded with mu.

@carlosperate

This comment has been minimized.

Copy link
Member

carlosperate commented Oct 8, 2018

Does that mean Mu does sometimes work with NVDA?

Would you be able to check if Mu is responsive without any screen reader at all?
Knowing if Mu opens correctly without one helps us immensely to reduce the debugging scope.

Finally, the error message you're seeing is because Python (which is also the language Mu is written in) has encountered a problem, rather than Mu having a problem itself. This more fundamental error suggests to me it's something like an issue with JAWS interacting with the Python language.

While I agree, we also need to keep in mind that if the Mu code locks up for whatever reason (I had it happen during development when I made some silly mistakes), the same type of error appears where it is reported that Python is not responding.

@sanchit002sanchit002

This comment has been minimized.

Copy link
Author

sanchit002sanchit002 commented Oct 8, 2018

@dangmanhcuong87

This comment has been minimized.

Copy link

dangmanhcuong87 commented Oct 10, 2018

Hi all. I've tried using MU twice with NVDA, and it was crashed once. Beside, it was crash all times using Jaws.

@tjguk tjguk added the 3rd party label Nov 11, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment