Permalink
Browse files

this is what will end up on CPAN as Set::Relation version 0.8.0 for P…

…erl 5
  • Loading branch information...
duncand committed Mar 24, 2009
1 parent aa5a700 commit 90a17d9bbd0b551dde5b925781244e72c00124d5
Showing with 15 additions and 15 deletions.
  1. +1 −1 Changes
  2. +1 −1 Makefile.PL
  3. +2 −2 lib/Set/Relation.pm
  4. +4 −4 lib/Set/Relation/V1.pm
  5. +4 −4 lib/Set/Relation/V2.pm
  6. +3 −3 t/Set_Relation_00_Compile.t
View
@@ -1,7 +1,7 @@
Set::Relation
---------------------------------------------------------------------------
-2009-03-xx Darren Duncan <perl@DarrenDuncan.net>
+2009-03-23 Darren Duncan <perl@DarrenDuncan.net>
* Set::Relation version 0.8.0 for Perl 5 is released on CPAN as
Set-Relation-0.8.0.tar.gz.
View
@@ -7,7 +7,7 @@ use ExtUtils::MakeMaker;
WriteMakefile(
'NAME' => 'Set::Relation',
- 'VERSION' => '0.7.0',
+ 'VERSION' => '0.8.0',
'ABSTRACT' => 'Relation data type for Perl',
'AUTHOR' => 'Darren Duncan <perl@DarrenDuncan.net>',
'LICENSE' => 'lgpl',
View
@@ -7,7 +7,7 @@ use warnings FATAL => 'all';
###########################################################################
{ package Set::Relation; # role
- use version 0.74; our $VERSION = qv('0.7.0');
+ use version 0.74; our $VERSION = qv('0.8.0');
# Note: This given version applies to all of this file's packages.
use Moose::Role 0.72;
@@ -122,7 +122,7 @@ Relation data type for Perl
=head1 VERSION
-This document describes Set::Relation version 0.7.0 for Perl 5.
+This document describes Set::Relation version 0.8.0 for Perl 5.
=head1 SYNOPSIS
View
@@ -3,13 +3,13 @@ use utf8;
use strict;
use warnings FATAL => 'all';
-use Set::Relation 0.007000;
+use Set::Relation 0.008000;
###########################################################################
###########################################################################
{ package Set::Relation::V1; # class
- use version 0.74; our $VERSION = qv('0.7.0');
+ use version 0.74; our $VERSION = qv('0.8.0');
use Scalar::Util 'refaddr';
use List::MoreUtils 'any', 'all', 'notall', 'uniq';
@@ -3017,7 +3017,7 @@ Bundled original implementation of Set::Relation role
=head1 VERSION
-This document describes Set::Relation::V1 version 0.7.0 for Perl 5.
+This document describes Set::Relation::V1 version 0.8.0 for Perl 5.
=head1 SYNOPSIS
@@ -3189,7 +3189,7 @@ L<List::MoreUtils-ver(0.22..*)|List::MoreUtils>,
L<Moose-ver(0.72..*)|Moose>.
It also requires these Perl 5 packages that are in the current
-distribution: L<Set::Relation-ver(0.7.0..*)|Set::Relation>.
+distribution: L<Set::Relation-ver(0.8.0..*)|Set::Relation>.
=head1 INCOMPATIBILITIES
View
@@ -3,13 +3,13 @@ use utf8;
use strict;
use warnings FATAL => 'all';
-use Set::Relation 0.007000;
+use Set::Relation 0.008000;
###########################################################################
###########################################################################
{ package Set::Relation::V2; # class
- use version 0.74; our $VERSION = qv('0.7.0');
+ use version 0.74; our $VERSION = qv('0.8.0');
use Scalar::Util 'refaddr';
use List::MoreUtils 'any', 'all', 'notall', 'uniq';
@@ -3039,7 +3039,7 @@ Bundled second implementation of Set::Relation role
=head1 VERSION
-This document describes Set::Relation::V2 version 0.7.0 for Perl 5.
+This document describes Set::Relation::V2 version 0.8.0 for Perl 5.
=head1 SYNOPSIS
@@ -3092,7 +3092,7 @@ L<List::MoreUtils-ver(0.22..*)|List::MoreUtils>,
L<Moose-ver(0.72..*)|Moose>.
It also requires these Perl 5 packages that are in the current
-distribution: L<Set::Relation-ver(0.7.0..*)|Set::Relation>.
+distribution: L<Set::Relation-ver(0.8.0..*)|Set::Relation>.
=head1 INCOMPATIBILITIES
@@ -10,15 +10,15 @@ use Test::More;
plan( 'tests' => 6 );
use_ok( 'Set::Relation' );
-is( $Set::Relation::VERSION, qv('0.7.0'),
+is( $Set::Relation::VERSION, qv('0.8.0'),
'Set::Relation is the correct version' );
use_ok( 'Set::Relation::V1' );
-is( $Set::Relation::V1::VERSION, qv('0.7.0'),
+is( $Set::Relation::V1::VERSION, qv('0.8.0'),
'Set::Relation::V1 is the correct version' );
use_ok( 'Set::Relation::V2' );
-is( $Set::Relation::V2::VERSION, qv('0.7.0'),
+is( $Set::Relation::V2::VERSION, qv('0.8.0'),
'Set::Relation::V2 is the correct version' );
1; # Magic true value required at end of a reusable file's code.

0 comments on commit 90a17d9

Please sign in to comment.