New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

mumble qt5 build no systray icon help #1498

Closed
anexation opened this Issue Dec 13, 2014 · 6 comments

Comments

Projects
None yet
5 participants
@anexation

anexation commented Dec 13, 2014

Hi,

I compiled mumble off of qt5 and runs great and good job by the way on this program... I run kde plasma 5 with qt 5.4 and my issue is the icon in the system tray is blank.. You can see a blank spot where an icon would be.. Maybe a mistake on my part but any help is greatly appreciated..

pkgbuild: https://aur.archlinux.org/packages/mumble-qt5-git/

image

@anexation

This comment has been minimized.

anexation commented Dec 13, 2014

After some further investigation, If I have "Show talking status in tray icon" enable is when the icon is absent but if i disable it the icon is there? what name of svg icons is it looking for for talking status etc.. If you look at the top panel the icon is now there enabling as said above..

image

@DarkArc

This comment has been minimized.

DarkArc commented Dec 22, 2014

I can confirm this issue.

Edit: However for me it seems that that the "Show talking status in tray icon" setting doesn't show the icon either.

@mkrautz

This comment has been minimized.

Member

mkrautz commented Dec 28, 2014

Thanks, I can reproduce as well. Looking into it.

@mkrautz mkrautz added this to the 1.3.0 milestone Jan 3, 2015

@DarkArc

This comment has been minimized.

DarkArc commented Jan 13, 2015

This appears to be related to a Qt5 regression. Links to relevant bugs can be found in this stack overflow discussion: http://stackoverflow.com/questions/25314391/system-tray-icon-doesnt-show-in-qt5-linux-lxde.

@msva

This comment has been minimized.

msva commented May 9, 2016

just note: I tried Qt systray example and icon there works fine and don't lags/disappears, while Mumble's disappears after connecting to server (when "show talking status" is active).

So, it is, probably, Mumble bug, but not Qt.

Qt: 5.6.0
KDE: 5.21.0

@mkrautz mkrautz self-assigned this Feb 7, 2017

@davidebeatrici

This comment has been minimized.

Member

davidebeatrici commented Nov 29, 2017

Issue tracked in #3124.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment