Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

overlay: remove use of d3dx9, d3dx10 and d3dx11. #2522

Merged
merged 1 commit into from Aug 24, 2016

Conversation

@mkrautz
Copy link
Member

commented Aug 21, 2016

No description provided.

@hacst

This comment has been minimized.

Copy link
Member

commented Aug 24, 2016

LGTM

mkrautz added a commit that referenced this pull request Aug 24, 2016
Merge PR #2527: Allow Mumble to be built with MSVC2015
This PR adds a toolchain file, and includes various small fixups that are needed to make Mumble build on MSVC2015.

This PR, by itself, allows both Mumble and Murmur to build, but the x64 overlay and some plugins do not build without extra PRs. These are:

#2522
#2523

MSVC2015 also shows a few new warnings. These are fixed in the following PRs:
#2525
#2524

And, to finish off, PR #2526 enables warnings by default on Windows when in a buildenv. I used this when fixing the tree.

@mkrautz mkrautz merged commit a017810 into mumble-voip:master Aug 24, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.