Skip to content
Permalink
Browse files

strace: Only allow libdw or libunwind

These two dependencies are mutual exclusive and it is only possible to
select one of them, change the select to a chose so it is only possible
to select one of them in OpenWrt menu config.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  • Loading branch information...
hauke committed Feb 16, 2019
1 parent b494734 commit ce8226a97133a7b105d9c626ff47a401b61748cd
Showing with 11 additions and 9 deletions.
  1. +11 −9 package/devel/strace/Makefile
@@ -57,17 +57,19 @@ system calls a program makes while it is running.
endef

define Package/strace/config
menu "Select strace configuration options"
depends on PACKAGE_strace
choice
prompt "stack tracing support"
default STRACE_NONE

config STRACE_LIBDW
bool "Enable stack tracing support using libdw"
default n
config STRACE_LIBUNWIND
bool "Enable stack tracing support using libunwind (experimental)"
default n
config STRACE_NONE
bool "None"

endmenu
config STRACE_LIBDW
bool "libdw"

config STRACE_LIBUNWIND
bool "libunwind (experimental)"
endchoice
endef

CONFIGURE_ARGS += \

0 comments on commit ce8226a

Please sign in to comment.
You can’t perform that action at this time.