Skip to content
Find file
Fetching contributors…
Cannot retrieve contributors at this time
28 lines (22 sloc) 1.33 KB
# -*- encoding: utf-8 -*-
$:.push File.expand_path("../lib", __FILE__)
# Maintain your gem's version:
require "find_cache/version"
# Describe your gem and declare its dependencies:
Gem::Specification.new do |s|
s.name = "find_cache"
s.version = FindCache::VERSION
s.authors = ["Mustafa Turan"]
s.email = ["mustafaturan.net@gmail.com"]
s.homepage = "https://github.com/mustafaturan/find_cache"
s.summary = "Cache for ActiveRecord >=3.0.0 find_by_PrimaryKey(id) and find_by_(attr) methods based on Rails.cache methods."
s.description = "Makes ActiveRecord >=3.0.0 'find_by_id, find_by_(attr)' methods and 'has_one, belongs_to relations' cacheable by PK(id) or any referenced columns using Rails.cache methods. It also supports fetching multiple records using PKs(ids) with find_all_cache method(if cache store supports multiple reads [hint: memcache_store, dalli_store support.])."
s.files = Dir["{app,config,db,lib}/**/*"] + ["CHANGE-LOG", "MIT-LICENSE", "Rakefile", "README.rdoc"]
s.test_files = Dir["test/**/*"]
s.add_dependency "activerecord", [">= 3.0.0"]
s.add_dependency "activesupport", [">= 3.0.0"]
s.add_dependency "simple_uuid", [">= 0.2.0"]
s.add_development_dependency "rails", "~> 3.2.0"
s.add_development_dependency "sqlite3"
s.add_development_dependency "dalli", "~> 2.1.0"
end
Something went wrong with that request. Please try again.