Permalink
Browse files

remove shoulda depended gems, too complex

  • Loading branch information...
1 parent d5e9d99 commit e49ab26399a6c083f351d25736f34b15d33dc3d8 @mvj3 committed Mar 11, 2013
Showing with 12 additions and 114 deletions.
  1. +1 −0 .gitignore
  2. +1 −10 Gemfile
  3. +0 −43 Rakefile
  4. +0 −1 VERSION
  5. +10 −59 only_one_rake.gemspec
  6. +0 −1 test/helper.rb
View
@@ -48,3 +48,4 @@ pkg
# For rubinius:
#*.rbc
Gemfile.lock
+*.gem
View
11 Gemfile
@@ -1,11 +1,2 @@
source "http://rubygems.org"
-
-# Add dependencies to develop your gem here.
-# Include everything needed to run rake, tests, features, etc.
-group :development do
- gem "shoulda", ">= 0"
- gem "rdoc", "~> 3.12"
- gem "bundler", ">= 1.0.0"
- gem "jeweler", "~> 1.8.4"
- gem "simplecov"
-end
+gemspec
View
@@ -10,46 +10,3 @@ rescue Bundler::BundlerError => e
exit e.status_code
end
require 'rake'
-
-require 'jeweler'
-Jeweler::Tasks.new do |gem|
- # gem is a Gem::Specification... see http://docs.rubygems.org/read/chapter/20 for more options
- gem.name = "only_one_rake"
- gem.homepage = "http://github.com/mvj3/only_one_rake"
- gem.license = "MIT"
- gem.summary = %Q{ensure only one rake is running at a time}
- gem.description = gem.summary
- gem.email = "mvjome@gmail.com"
- gem.authors = ["David Chen"]
- # dependencies defined in Gemfile
-end
-Jeweler::RubygemsDotOrgTasks.new
-
-require 'rake/testtask'
-Rake::TestTask.new(:test) do |test|
- test.libs << 'lib' << 'test'
- test.pattern = 'test/**/test_*.rb'
- test.verbose = true
-end
-
-=begin
-require 'rcov/rcovtask'
-Rcov::RcovTask.new do |test|
- test.libs << 'test'
- test.pattern = 'test/**/test_*.rb'
- test.verbose = true
- test.rcov_opts << '--exclude "gems/*"'
-end
-=end
-
-task :default => :test
-
-require 'rdoc/task'
-Rake::RDocTask.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
-
- rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "only_one_rake #{version}"
- rdoc.rdoc_files.include('README*')
- rdoc.rdoc_files.include('lib/**/*.rb')
-end
View
@@ -1 +0,0 @@
-0.0.3
View
@@ -1,61 +1,12 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
-# -*- encoding: utf-8 -*-
-
Gem::Specification.new do |s|
- s.name = "only_one_rake"
- s.version = "0.0.3"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["David Chen"]
- s.date = "2013-01-15"
- s.description = "ensure only one rake is running at a time"
- s.email = "mvjome@gmail.com"
- s.extra_rdoc_files = [
- "LICENSE.txt",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- "Gemfile",
- "LICENSE.txt",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "lib/only_one_rake.rb",
- "only_one_rake.gemspec",
- "test/helper.rb",
- "test/test_only_one_rake.rb"
- ]
- s.homepage = "http://github.com/mvj3/only_one_rake"
- s.licenses = ["MIT"]
- s.require_paths = ["lib"]
- s.rubygems_version = "1.8.10"
- s.summary = "ensure only one rake is running at a time"
-
- if s.respond_to? :specification_version then
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<shoulda>, [">= 0"])
- s.add_development_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_development_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.8.4"])
- s.add_development_dependency(%q<simplecov>, [">= 0"])
- else
- s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.8.4"])
- s.add_dependency(%q<simplecov>, [">= 0"])
- end
- else
- s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.8.4"])
- s.add_dependency(%q<simplecov>, [">= 0"])
- end
+ s.name = "only_one_rake"
+ s.version = "0.0.4"
+ s.date = '2013-03-11'
+ s.summary = "ensure only one rake is running at a time"
+ s.description = s.summary
+ s.authors = ["David Chen"]
+ s.email = 'mvjome@gmail.com'
+ s.files = ["lib/only_one_rake.rb"]
+ s.homepage = 'http://rubygems.org/gems/only_one_rake'
+ s.licenses = ["MIT"]
end
-
View
@@ -8,7 +8,6 @@
exit e.status_code
end
require 'test/unit'
-require 'shoulda'
$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
$LOAD_PATH.unshift(File.dirname(__FILE__))

0 comments on commit e49ab26

Please sign in to comment.