Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WebVM fails to start on Linux system with no swap #2

Closed
GoogleCodeExporter opened this issue Mar 13, 2015 · 1 comment
Closed

WebVM fails to start on Linux system with no swap #2

GoogleCodeExporter opened this issue Mar 13, 2015 · 1 comment

Comments

@GoogleCodeExporter
Copy link

@GoogleCodeExporter GoogleCodeExporter commented Mar 13, 2015

What steps will reproduce the problem?
1. Turn off swap
2. the application fails to deploy on Glassfish:
3.

What is the expected output? What do you see instead?
The application should work, instead it fails with:

Application server startup complete.
The ProblemSampler timer failed
java.lang.ArithmeticException: / by zero
at 
sk.baka.webvm.analyzer.ProblemAnalyzer.getHostVirtMemReport(ProblemAnalyzer
.java:193)
at 
sk.baka.webvm.analyzer.ProblemAnalyzer.getProblems(ProblemAnalyzer.java:166
)
at 
sk.baka.webvm.analyzer.HistorySampler$ProblemSampler.run(HistorySampler.jav
a:182)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at 
java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
at 
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access
$101(ScheduledThreadPoolExecutor.java:98)
at 
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPer
iodic(ScheduledThreadPoolExecutor.java:181)
at 
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Sc
heduledThreadPoolExecutor.java:205)
at 
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.j
ava:886)
at 
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:
908)
at java.lang.Thread.run(Thread.java:619)

Please use labels and text to provide additional information.

Original issue reported on code.google.com by martin.v...@gmail.com on 2 Feb 2010 at 6:21

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Mar 13, 2015

Fixed in r285

Original comment by martin.v...@gmail.com on 2 Feb 2010 at 6:21

  • Changed state: Fixed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant