Rack::Lint::LintError #21

volkanunsal opened this Issue Jul 12, 2012 · 1 comment

3 participants


I am getting an ecndoign error when I try to use this gem with Rack Lint. Here is the stack trace. I hope someone else can look at it.

Rack::Lint::LintError: rack.input #StringIO:0x007fef1cf2dce0 does not have ASCII-8BIT as its external encoding
from /Users/newuser/.rvm/gems/ruby-1.9.3-p125@global/gems/rack-1.4.1/lib/rack/lint.rb:19:in assert'
from /Users/newuser/.rvm/gems/ruby-1.9.3-p125@global/gems/rack-1.4.1/lib/rack/lint.rb:271:in
from /Users/newuser/.rvm/gems/ruby-1.9.3-p125@global/gems/rack-1.4.1/lib/rack/lint.rb:226:in check_env'
from /Users/newuser/.rvm/gems/ruby-1.9.3-p125@global/gems/rack-1.4.1/lib/rack/lint.rb:42:in
from /Users/newuser/.rvm/gems/ruby-1.9.3-p125@global/gems/rack-1.4.1/lib/rack/lint.rb:36:in call'
from /Users/newuser/.rvm/gems/ruby-1.9.3-p125@global/gems/rack-1.4.1/lib/rack/builder.rb:134:in
from /Users/newuser/.rvm/gems/ruby-1.9.3-p125@whatnow/bundler/gems/weary-0c8b902c8a80/lib/weary/request.rb:49:in call'
from /Users/newuser/.rvm/gems/ruby-1.9.3-p125@whatnow/bundler/gems/weary-0c8b902c8a80/lib/weary/request.rb:129:in
block in perform'

@mwunsch mwunsch closed this in 07ee5ae Sep 15, 2012

Ran into the same issue. Was using 1.1.2. Tried 1.1.3, but the dependencies didn't work out using Jruby.
Bundler could not find compatible versions for gem "rack":
In Gemfile:
rails (= 3.2.3) java depends on
rack (~> 1.4.0) java

weary (~> 1.1.3) java depends on
  rack (1.5.2)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment