Permalink
Browse files

Update Package.swift (#923)

* Update Package.swift

Updating Package.swift to add support for Swift 4.2

* adding support for Swift 4.2 without break support for older versions of Swift 4
  • Loading branch information...
heyzooi authored and mxcl committed Sep 23, 2018
1 parent f7e4db8 commit 4cd8a0d94b2f6dce555ec838644c81de7f9f0595
Showing with 30 additions and 0 deletions.
  1. +30 −0 Package@swift-4.2.swift
View
@@ -0,0 +1,30 @@
// swift-tools-version:4.2
import PackageDescription
let pkg = Package(name: "PromiseKit")
pkg.products = [
.library(name: "PromiseKit", targets: ["PromiseKit"]),
]
let pmk: Target = .target(name: "PromiseKit")
pmk.path = "Sources"
pmk.exclude = [
"AnyPromise.swift",
"AnyPromise.m",
"PMKCallVariadicBlock.m",
"dispatch_promise.m",
"join.m",
"when.m",
"NSMethodSignatureForBlock.m",
"after.m",
"hang.m",
"race.m",
"Deprecations.swift"
]
pkg.swiftLanguageVersions = [.v3, .v4, .v4_2]
pkg.targets = [
pmk,
.testTarget(name: "A+", dependencies: ["PromiseKit"]),
.testTarget(name: "CorePromise", dependencies: ["PromiseKit"], path: "Tests/CorePromise"),
]

0 comments on commit 4cd8a0d

Please sign in to comment.