Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

is snappy support really on? #46

Closed
pconstr opened this Issue Aug 24, 2012 · 4 comments

Comments

Projects
None yet
3 participants

pconstr commented Aug 24, 2012

I'm getting this when trying to open a database created by a earlier version of node-leveldb

Corruption: corrupted compressed block contents

This discussion suggests the error might be caused by leveldb being built without snappy support: http://comments.gmane.org/gmane.comp.db.leveldb/911

Collaborator

justmoon commented Aug 28, 2012

It looks like the compiler flag enabling snappy was incorrect. Can you check if this fixed the issue for you?

pconstr commented Aug 28, 2012

works for me thanks :)
I'm looking forward to the npm release

Owner

my8bird commented Aug 28, 2012

@justmoon if you happy with this I will push up a new version tonight.

Collaborator

justmoon commented Aug 28, 2012

Gopher it! Uh.. I mean: Go for it!

@justmoon justmoon closed this Aug 28, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment