Permalink
Browse files

Update README.md

  • Loading branch information...
1 parent 3536afe commit 7185e9f53e9b1626ed55493d76529fade5888b68 @myfreeweb committed Jul 24, 2012
Showing with 3 additions and 8 deletions.
  1. +3 −8 README.md
View
@@ -1,7 +1,7 @@
# startproject #
-Simplest Emacs project starter for all you framework guys — Django, Sproutcore, whatever — they have start commands. Really, the name „startproject“ is from Django‘s script :-)
+Simplest Emacs project starter for all you framework people — Django, Sproutcore, whatever — they have start commands. Really, the name „startproject“ is from Django‘s script :-)
-It just runs framework‘s **start command** (or just a simple **tar** command extracting your project skeleton... or a **mkdir** if you‘re not a framework guy) and opens the newly created project with **dired**. Also it can initialize version control (bzr/hg/git) and open **vc-dir**.
+It just runs framework‘s **start command** (or just a simple **tar** command extracting your project skeleton... or a **mkdir** if you‘re not a framework person) and opens the newly created project with **dired**. Also it can initialize version control (bzr/hg/git) and open **vc-dir**.
Requires a modern **Emacs** and **ido**. ido usually works out of the box, *at least* with GNU Emacs from Ubuntu repos and Aquamacs for Mac.
@@ -27,14 +27,9 @@ Requires a modern **Emacs** and **ido**. ido usually works out of the box, *at l
A: You forgot slashes in the projects-dir.
- Q: Why I have to add a command for my favorite framework by hand? It‘s popular.
- A: Because I‘m lazy to google these commands for all the mainstream frameworks. Just [email me](mailto:me@myfreeweb.ru) a command for your thing.
+ A: Because I‘m too lazy to google these commands for all the mainstream frameworks. Feel free to open a pull request.
- Q: I don‘t need to open vc-dir! Can I turn it off?
A: Of course! Just put it in your init file:
`(setq sp-open-vc-dir nil)`
-- Q: Why it requires ido?
- A: Ido is very awesome! I can‘t believe you don‘t have it installed. It **must** come with your Emacs!
-- Q: Why Emacs?
-
- A: Because vim sucks!

0 comments on commit 7185e9f

Please sign in to comment.