Permalink
Browse files

aclocal: require 1.13

Require aclocal-1.13 so that AC_CONFIG_MACRO_DIR() actually does
something useful when ACLOCAL isn't set. Our local macros weren't being
m4_include()d, with predictably confusing results.
  • Loading branch information...
1 parent 1bdbf3b commit e769561975e6185006798c0652e20ad583768af2 @achadwick achadwick committed May 27, 2016
Showing with 3 additions and 12 deletions.
  1. +3 −12 autogen.sh
View
@@ -9,14 +9,14 @@
# tools and you shouldn't use this script. Just call ./configure
# directly.
-ACLOCAL=${ACLOCAL-aclocal-1.11}
+ACLOCAL=${ACLOCAL-aclocal-1.13}
AUTOCONF=${AUTOCONF-autoconf}
AUTOHEADER=${AUTOHEADER-autoheader}
-AUTOMAKE=${AUTOMAKE-automake-1.11}
+AUTOMAKE=${AUTOMAKE-automake-1.13}
LIBTOOLIZE=${LIBTOOLIZE-libtoolize}
AUTOCONF_REQUIRED_VERSION=2.62
-AUTOMAKE_REQUIRED_VERSION=1.10.0
+AUTOMAKE_REQUIRED_VERSION=1.13
INTLTOOL_REQUIRED_VERSION=0.40.1
LIBTOOL_REQUIRED_VERSION=1.5
LIBTOOL_WIN32_REQUIRED_VERSION=2.2
@@ -136,15 +136,6 @@ elif (automake-1.14 --version) < /dev/null > /dev/null 2>&1; then
elif (automake-1.13 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.13
ACLOCAL=aclocal-1.13
-elif (automake-1.12 --version) < /dev/null > /dev/null 2>&1; then
- AUTOMAKE=automake-1.12
- ACLOCAL=aclocal-1.12
-elif (automake-1.11 --version) < /dev/null > /dev/null 2>&1; then
- AUTOMAKE=automake-1.11
- ACLOCAL=aclocal-1.11
-elif (automake-1.10 --version) < /dev/null > /dev/null 2>&1; then
- AUTOMAKE=automake-1.10
- ACLOCAL=aclocal-1.10
else
echo
echo " You must have automake $AUTOMAKE_REQUIRED_VERSION or newer installed to compile $PROJECT."

0 comments on commit e769561

Please sign in to comment.