Clarify README about required packages on ubuntu (12.04 to be precise) #60

Open
wants to merge 2 commits into
from

Projects

None yet

4 participants

@nerdcorenet

While following the README instrcutions I have been stopped at the 'vagrant up' command:

$ vagrant up
/home/mikem/git/ariadne-deploy/Vagrantfile:10:in `': undefined method `load_file' for YAML:Module (NoMethodError)
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/config/loader.rb:115:in `load'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/config/loader.rb:115:in `block in procs_for_source'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/config.rb:41:in `block in capture_configures'
    from :10:in `synchronize'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/config.rb:36:in `capture_configures'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/config/loader.rb:114:in `procs_for_source'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/config/loader.rb:51:in `block in set'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/config/loader.rb:45:in `each'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/config/loader.rb:45:in `set'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/environment.rb:377:in `block in load_config!'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/environment.rb:392:in `call'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/environment.rb:392:in `load_config!'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/lib/vagrant/environment.rb:327:in `load!'
    from /opt/vagrant/embedded/gems/gems/vagrant-1.0.5/bin/vagrant:40:in `'
    from /opt/vagrant/bin/../embedded/gems/bin/vagrant:19:in `load'
    from /opt/vagrant/bin/../embedded/gems/bin/vagrant:19:in `'

Seems a bit strange to me that 'load_file' should generate an 'undefined method' error...

I'm using Vagrant 1.0.5 dpkg installed on Ubuntu 10.04 LTS x86_64 with VirtualBox 4.1.22. Vagrant and VBox are both functioning, as I can 'vagrant up' lucid32.box or lucid64.box, but when I try using the Ariadne Vagrantfile it fails as above.

Not sure if it's related but the only package from the README I did not install was libreadline-dplv2-dev because it is not in the 10.04 apt repository:

E: Couldn't find package libreadline-gplv2-dev

@patcon

Hm. I haven't tried to get Ariadne working on ubuntu myself. Any thoughts @mparker?

@mparker17 mparker17 was assigned Oct 3, 2012
@mparker17

I needed to install all of the packages listed in the README before Ariadne worked on 12.04, so I'd strongly suspect that the missing library is the cause of the issue.

According to the Ubuntu package database, the 12.04 libreadline-gplv2-dev package installs libreadline version 5. In Ubuntu 10.04, there is not a package named libreadline-gplv2-dev, but there are two packages for libreadline-dev version 5, lib32readline5-dev and lib64readline5-dev, apparently for 32-bit and 64-bit architectures respectively. If I were you, I'd try installing the appropriate one and seeing if that solves the issue.


All that being said, the last time I tested Ariadne on Ubuntu was with Ariadne versions 1.0.0 and 1.1.0, so I'll look in to testing the latest versions of Ariadne on 12.04 to see if I get the same errors.

@patcon

Thanks @mparker17 :)

Ah and also @nerdcorenet, we stumbled across an issue with the vagrant's official stock lucid64 basebox.. The vagrant maintainer is aware of the issue and working to fix it, particularly since it means that (since early sept), anyone who's tried vagrant for the first time has likely run into mysterious errors.

For now, I've hosted a past version of the lucid64 basebox which should work. You can add it like so:

vagrant box remove lucid64 # If one has already been installed
vagrant box add lucid64 https://github.com/downloads/myplanetdigital/ariadne/lucid64.box

In the next release, anyone launching Ariadne for the first time will get our basebox, so it will be a non-issue :)

@mparker17

@nerdcorenet posted the following comment to another Ariadne issue:


This will not help you mparker17 but I am having problems on Ubuntu 12.04 as well, in a similar place. The README didn't say anything about these packages but I've also needed to install these to facilitate nokogiri-1.5.0:

libxml2-dev
libxslt1-dev

If those could be added to the docs that would be grand. :)


His comment was unrelated to the issue he posted to, but directly related to this issue, so I'm re-posting it here and deleting it from the other issue.

@patcon

I saw you were working on ubuntu precise earlier @mparker. Can you confirm these requirements? do you have them on your lucid machine as well? Think I should add them to the readme at this point?

@mparker
@mparker17

Lol, I'll take care of it. Thanks! :D

@mparker17

Confirmed that the gem nokogiri requires libxml2, libxml2-dev, libxslt1.1 and libxslt1-dev.

Will transform this issue into a pull request with appropriate changes to the README.

@mparker17 mparker17 referenced this pull request Oct 11, 2012
Merged

Cleanup readme #69

@patcon

Awesome, thanks matt! Looks like libxml2-dev pulls in libxml2 and same for libxslt1-dev.

Can we only add the two packages to the README? libxml2-dev libxslt1-dev

@mparker17 mparker17 task by @patcon: libxml2-dev depends on libxml2 and libxslt1-dev depe…
…nds on libxslt1.1 so they don't all need to be listed
85acefc
@mparker17

Done.

@patcon

Also noticed that libssl-dev pulls in zlib1g-dev (using aptitude show libssl-dev)

@patcon

I'll check on them all and see how small we can get that apt-get install list later. minor obvously

@mparker17

See also pull request GH-69

@patcon

apt-get install build-essential libssl-dev libreadline5 nfs-kernel-server libxml2-dev libxslt1-dev

Also, I'm seeing that lucid64 uses lib32readline5-dev too. Only squeeze64 seems to use lib64readline5-dev:
http://packages.debian.org/search?keywords=lib64readline5-dev

@mparker17

Also noticed that libssl-dev pulls in zlib1g-dev (using aptitude show libssl-dev)
I'll check on them all and see how small we can get that apt-get install list later. minor obvously
Also, I'm seeing that lucid64 uses lib32readline5-dev too. Only squeeze64 seems to use lib64readline5-dev:
http://packages.debian.org/search?keywords=lib64readline5-dev

It'll be a lot easier for me to do this on my home computer; I'll do it.

@mparker17 mparker17 was assigned Oct 11, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment