Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 51 lines (42 sloc) 1.758 kB
a981eb2 @myronmarston Deal with weird load path issue on jruby.
authored
1 $LOAD_PATH.unshift File.expand_path("../lib", __FILE__)
2 require "vcr/version"
6c7e2e2 @myronmarston Adding gemspec.
authored
3
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
4 Gem::Specification.new do |s|
5 s.name = "vcr"
6 s.homepage = "http://github.com/myronmarston/vcr"
6c7e2e2 @myronmarston Adding gemspec.
authored
7 s.authors = ["Myron Marston"]
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
8 s.summary = "Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests."
9 s.description = "VCR provides helpers to record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests. It works with any ruby testing framework, and provides built-in support for cucumber."
10 s.email = "myron.marston@gmail.com"
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
11 s.require_path = "lib"
12 s.files = `git ls-files`.split("\n")
0211741 @myronmarston We have no test or bin dir.
authored
13 s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
6c7e2e2 @myronmarston Adding gemspec.
authored
14
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
15 s.version = VCR.version
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
16 s.platform = Gem::Platform::RUBY
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
17 s.required_ruby_version = '>= 1.8.6'
18 s.required_rubygems_version = '>= 1.3.5'
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
19
20 {
bde0268 @myronmarston Update bundler and relish gems to latest.
authored
21 'bundler' => '~> 1.0.7',
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
22 'rake' => '~> 0.8.7',
23
535e264 @myronmarston Upgrade RSpec.
authored
24 'rspec' => '~> 2.4.0',
b7e4d2d @myronmarston Update cucumber.
authored
25 'cucumber' => '~> 0.9.4',
89748b9 @myronmarston Add aruba for use in cucumber features.
authored
26 'aruba' => '~> 0.2.1',
6772666 @myronmarston Put shoulda in the gemspec since it is used by one of the cukes and i…
authored
27 'shoulda' => '~> 2.9.2',
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
28
29 'fakeweb' => '~> 1.3.0',
0418416 @myronmarston Upgrade to WebMock 1.6.0.
authored
30 'webmock' => '~> 1.6.0',
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
31
39b219d @myronmarston Add faraday dev dependency.
authored
32 'faraday' => '~> 0.5.3',
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
33 'httpclient' => '~> 2.1.5.2',
34
acb7e63 @myronmarston Added timecop so we can simulate the passage of time in our tests.
authored
35 'timecop' => '~> 0.3.5',
15d027e @myronmarston New cuke: basic_usage.feature.
authored
36 'rack' => '1.1.0',
37 'sinatra' => '~> 1.1.0'
65f1424 @myronmarston Fix webmock dependency declaration to work on ruby 1.8.6.
authored
38 }.each do |lib, version|
39 s.add_development_dependency lib, version
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
40 end
41
42 {
43 'patron' => '~> 0.4.6',
44 'em-http-request' => '~> 0.2.7',
c0acf8f @myronmarston Update to the just released Typhoeus 0.2.0.
authored
45 'curb' => '~> 0.7.8',
bdabbb3 @myronmarston Updated typhoeus to latest 0.2.1 release.
authored
46 'typhoeus' => '~> 0.2.1'
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
47 }.each do |lib, version|
48 s.add_development_dependency lib, version
49 end unless RUBY_PLATFORM == 'java'
6c7e2e2 @myronmarston Adding gemspec.
authored
50 end
Something went wrong with that request. Please try again.