Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 52 lines (42 sloc) 2.156 kB
a981eb2 @myronmarston Deal with weird load path issue on jruby.
authored
1 $LOAD_PATH.unshift File.expand_path("../lib", __FILE__)
2 require "vcr/version"
6c7e2e2 @myronmarston Adding gemspec.
authored
3
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
4 Gem::Specification.new do |s|
5 s.name = "vcr"
6 s.homepage = "http://github.com/myronmarston/vcr"
6c7e2e2 @myronmarston Adding gemspec.
authored
7 s.authors = ["Myron Marston"]
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
8 s.summary = "Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests."
78a8028 @myronmarston Update gem description.
authored
9 s.description = "VCR provides a simple API to record and replay your test suite's HTTP interactions. It works with a variety of HTTP client libraries, HTTP stubbing libraries and testing frameworks."
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
10 s.email = "myron.marston@gmail.com"
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
11 s.require_path = "lib"
12 s.files = `git ls-files`.split("\n")
0211741 @myronmarston We have no test or bin dir.
authored
13 s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
6c7e2e2 @myronmarston Adding gemspec.
authored
14
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
15 s.version = VCR.version
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
16 s.platform = Gem::Platform::RUBY
4441654 @myronmarston Update gemspec to reflect that VCR no longer supports 1.8.6.
authored
17 s.required_ruby_version = '>= 1.8.7'
dd461d5 @myronmarston Removed dependency on jeweler. Manage the gemspec by hand instead. …
authored
18 s.required_rubygems_version = '>= 1.3.5'
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
19
9e49c5b @mislav allow bundler 1.1
mislav authored
20 s.add_development_dependency 'bundler', '>= 1.0.7'
51f6146 @myronmarston Less meta in the gemspec.
authored
21 s.add_development_dependency 'rake', '~> 0.9.2'
22
e7dc0a9 @myronmarston Update cucumber and aruba.
authored
23 s.add_development_dependency 'cucumber', '~> 1.1.4'
24 s.add_development_dependency 'aruba', '~> 0.4.11'
51f6146 @myronmarston Less meta in the gemspec.
authored
25
661450a @myronmarston Update RSpec.
authored
26 s.add_development_dependency 'rspec', '~> 2.11'
51f6146 @myronmarston Less meta in the gemspec.
authored
27 s.add_development_dependency 'shoulda', '~> 2.9.2'
28
29 s.add_development_dependency 'fakeweb', '~> 1.3.0'
e298c6c @myronmarston Update to released versions of things.
authored
30 s.add_development_dependency 'webmock', '~> 1.9'
e57ae60 @myronmarston Updated Gemfile/gemspec/Rakefile, etc to use latest best practices ba…
authored
31
c5b249a @myronmarston Relax the faraday version constraint.
authored
32 s.add_development_dependency 'faraday', '~> 0.8'
8575ba5 @myronmarston Relax httpclient version constraint.
authored
33 s.add_development_dependency 'httpclient', '~> 2.2'
4a3ed8b @myronmarston Test against new webmock, excon and em-http-request releases.
authored
34 s.add_development_dependency 'excon', '>= 0.11.0', '< 1.0'
51f6146 @myronmarston Less meta in the gemspec.
authored
35
36 s.add_development_dependency 'timecop', '~> 0.3.5'
183592b @myronmarston Update sinatra and rack dependency.
authored
37 s.add_development_dependency 'rack', '~> 1.3.6'
38 s.add_development_dependency 'sinatra', '~> 1.3.2'
51f6146 @myronmarston Less meta in the gemspec.
authored
39 s.add_development_dependency 'multi_json', '~> 1.0.3'
a299c20 @myronmarston Append info about the preserve bytes option to serialization encoding…
authored
40 s.add_development_dependency 'json', '~> 1.6.5'
6d435d1 @myronmarston It's simplecov, not simple_cov.
authored
41 s.add_development_dependency 'simplecov', '~> 0.5.3'
fd6bbaa @myronmarston Allow a custom storage backend to be used.
authored
42 s.add_development_dependency 'redis', '~> 2.2.2'
51f6146 @myronmarston Less meta in the gemspec.
authored
43
44 unless RUBY_PLATFORM == 'java'
45 s.add_development_dependency 'patron', '~> 0.4.15'
4a3ed8b @myronmarston Test against new webmock, excon and em-http-request releases.
authored
46 s.add_development_dependency 'em-http-request', '~> 1.0.2'
175b0ed @myronmarston Use a development version of webmock, and update Curb.
authored
47 s.add_development_dependency 'curb', '~> 0.8.0'
3bd2f22 @myronmarston Add regression spec for typhoeus/VCR bug found by @jeg2.
authored
48 s.add_development_dependency 'typhoeus', '~> 0.5.3'
ae138db @myronmarston yajl-ruby can't install on jruby 19 mode.
authored
49 s.add_development_dependency 'yajl-ruby', '~> 1.1.0'
51f6146 @myronmarston Less meta in the gemspec.
authored
50 end
6c7e2e2 @myronmarston Adding gemspec.
authored
51 end
Something went wrong with that request. Please try again.