Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Explicitly support newly released Excon 0.10.

  • Loading branch information...
commit 2aeea4a2000dc3a17312811ed269c26931d90909 1 parent 4d0d7bf
@myronmarston authored
Showing with 3 additions and 2 deletions.
  1. +1 −0  CHANGELOG.md
  2. +1 −1  lib/vcr/library_hooks/excon.rb
  3. +1 −1  vcr.gemspec
View
1  CHANGELOG.md
@@ -11,6 +11,7 @@
Thanks to [Patrick Schmitz](https://github.com/bullfight) and
[Dan Thompson](https://github.com/danthompson) for reporting the issue
and helping diagnose it.
+* Relax Excon dependency to include newly released 0.10.
## 2.0.0 RC 2 (February 23, 2012)
View
2  lib/vcr/library_hooks/excon.rb
@@ -2,7 +2,7 @@
require 'vcr/request_handler'
require 'excon'
-VCR::VersionChecker.new('Excon', Excon::VERSION, '0.9.6', '0.9').check_version!
+VCR::VersionChecker.new('Excon', Excon::VERSION, '0.9.6', '0.10').check_version!
module VCR
class LibraryHooks
View
2  vcr.gemspec
@@ -31,7 +31,7 @@ Gem::Specification.new do |s|
s.add_development_dependency 'faraday', '~> 0.7.2'
s.add_development_dependency 'httpclient', '~> 2.1.5.2'
- s.add_development_dependency 'excon', '~> 0.9.6'
+ s.add_development_dependency 'excon', '>= 0.9.6', '< 1.0'
s.add_development_dependency 'timecop', '~> 0.3.5'
s.add_development_dependency 'rack', '~> 1.3.6'
Please sign in to comment.
Something went wrong with that request. Please try again.