Skip to content
Browse files

Setup build for travis-ci.org.

- Lock patron to 0.4.9.  On travis-ci.org, my build failed because the newest patron uses a version of libcurl to new for the debian installation it uses.
- Setup ci:build.
  • Loading branch information...
1 parent 17926de commit 2e370079022120d3ff59ccd8ffcbcc4a4c3877e8 @myronmarston committed Feb 15, 2011
Showing with 19 additions and 2 deletions.
  1. +1 −0 .travis.yml
  2. +1 −1 Gemfile
  3. +16 −0 Rakefile
  4. +1 −1 vcr.gemspec
View
1 .travis.yml
@@ -0,0 +1 @@
+script: "rake ci:build"
View
2 Gemfile
@@ -4,7 +4,7 @@ gemspec
group :development do
# patron and em-http-request can't install on JRuby, so we have to limit their platform here.
platforms :ruby do
- gem 'patron', '~> 0.4.6'
+ gem 'patron', '0.4.9'
gem 'em-http-request', '~> 0.2.7'
gem 'curb', '~> 0.7.8'
gem 'typhoeus', '~> 0.2.1'
View
16 Rakefile
@@ -25,6 +25,22 @@ Cucumber::Rake::Task.new
task :default => [:spec, :cucumber]
+namespace :ci do
+ desc "Sets things up for a ci build on travis-ci.org"
+ task :setup do
+ sh "git submodule init"
+ sh "git submodule update"
+ end
+
+ RSpec::Core::RakeTask.new(:spec) do |t|
+ t.verbose = true
+ t.rspec_opts = %w[--format progress --backtrace]
+ end
+
+ desc "Run a ci build"
+ task :build => [:setup, :spec, :cucumber]
+end
+
desc "Push cukes to relishapp using the relish-client-gem"
task :relish do
require 'vcr/version'
View
2 vcr.gemspec
@@ -40,7 +40,7 @@ Gem::Specification.new do |s|
end
{
- 'patron' => '~> 0.4.6',
+ 'patron' => '0.4.9',
'em-http-request' => '~> 0.2.7',
'curb' => '~> 0.7.8',
'typhoeus' => '~> 0.2.1'

0 comments on commit 2e37007

Please sign in to comment.
Something went wrong with that request. Please try again.