Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Run tests against Faraday 0.8.0.rc2.

  • Loading branch information...
commit 72332bf25af0a591d12065389c9db226a49f8093 1 parent 8d356b1
@myronmarston authored
View
1  CHANGELOG.md
@@ -12,6 +12,7 @@
[Dan Thompson](https://github.com/danthompson) for reporting the issue
and helping diagnose it.
* Relax Excon dependency to include newly released 0.10.
+* Relax Faraday dependency to include 0.8.
* Fix Faraday library hook so that it always does the version checking.
## 2.0.0 RC 2 (February 23, 2012)
View
2  lib/vcr/middleware/faraday.rb
@@ -2,7 +2,7 @@
require 'vcr/util/version_checker'
require 'vcr/request_handler'
-VCR::VersionChecker.new('Faraday', Faraday::VERSION, '0.7.0', '0.7').check_version!
+VCR::VersionChecker.new('Faraday', Faraday::VERSION, '0.7.0', '0.8').check_version!
module VCR
# Contains middlewares for use with different libraries.
View
1  spec/vcr/library_hooks/faraday_spec.rb
@@ -5,7 +5,6 @@
it 'inserts the VCR middleware just before the adapter' do
conn = Faraday.new(:url => 'http://sushi.com') do |builder|
builder.request :url_encoded
- builder.request :json
builder.response :logger
builder.adapter :net_http
end
View
2  vcr.gemspec
@@ -29,7 +29,7 @@ Gem::Specification.new do |s|
s.add_development_dependency 'fakeweb', '~> 1.3.0'
s.add_development_dependency 'webmock', '~> 1.8.0'
- s.add_development_dependency 'faraday', '~> 0.7.2'
+ s.add_development_dependency 'faraday', '~> 0.8.0.rc2'
s.add_development_dependency 'httpclient', '~> 2.1.5.2'
s.add_development_dependency 'excon', '>= 0.9.6', '< 1.0'
Please sign in to comment.
Something went wrong with that request. Please try again.