Permalink
Browse files

Require FakeWeb 1.3.0 or greater.

  • Loading branch information...
myronmarston committed Aug 24, 2010
1 parent 5fc0ba4 commit a2a9f54d6b842ec713c77eecaa1a63af59921526
Showing with 4 additions and 4 deletions.
  1. +2 −2 lib/vcr/http_stubbing_adapters/fakeweb.rb
  2. +2 −2 spec/http_stubbing_adapters/fakeweb_spec.rb
@@ -9,8 +9,8 @@ class << self
LOCALHOST_REGEX = %r|\Ahttps?://((\w+:)?\w+@)?(#{VCR::LOCALHOST_ALIASES.map { |a| Regexp.escape(a) }.join('|')})(:\d+)?/|i
def check_version!
- unless meets_version_requirement?(::FakeWeb::VERSION, '1.2.8')
- raise "You are using FakeWeb #{::FakeWeb::VERSION}. VCR requires version 1.2.8 or greater."
+ unless meets_version_requirement?(::FakeWeb::VERSION, '1.3.0')
+ raise "You are using FakeWeb #{::FakeWeb::VERSION}. VCR requires version 1.3.0 or greater."
end
end
@@ -8,14 +8,14 @@
before(:each) { @orig_version = FakeWeb::VERSION }
after(:each) { FakeWeb::VERSION = @orig_version }
- %w( 1.2.8 1.2.9 1.2.10 1.3.0 1.10.0 2.0.0 ).each do |version|
+ %w( 1.3.0 1.3.1 1.4.0 1.10.0 2.0.0 ).each do |version|
it "does nothing when FakeWeb's version is #{version}" do
FakeWeb::VERSION = version
expect { described_class.check_version! }.to_not raise_error
end
end
- %w( 1.2.7 1.1.30 0.30.30 ).each do |version|
+ %w( 1.2.8 1.1.30 0.30.30 ).each do |version|
it "raises an error when FakeWeb's version is #{version}" do
FakeWeb::VERSION = version
expect { described_class.check_version! }.to raise_error(/You are using FakeWeb #{version}. VCR requires version .* or greater/)

0 comments on commit a2a9f54

Please sign in to comment.