Permalink
Browse files

Update to the just released Typhoeus 0.2.0.

  • Loading branch information...
1 parent 69715e3 commit c0acf8f0e85bd4a64d5443291adec0cb16854fac @myronmarston committed Nov 11, 2010
Showing with 10 additions and 15 deletions.
  1. +1 −1 Gemfile
  2. +2 −8 Gemfile.lock
  3. +2 −2 lib/vcr/http_stubbing_adapters/typhoeus.rb
  4. +3 −3 spec/http_stubbing_adapters/typhoeus_spec.rb
  5. +2 −1 vcr.gemspec
View
@@ -7,7 +7,7 @@ group :development do
gem 'patron', '~> 0.4.6'
gem 'em-http-request', '~> 0.2.7'
gem 'curb', '~> 0.7.8'
- gem 'typhoeus', :git => 'git://github.com/myronmarston/typhoeus.git', :branch => 'vcr_changes'
+ gem 'typhoeus', '~> 0.2.0'
end
platforms :jruby do
View
@@ -1,10 +1,3 @@
-GIT
- remote: git://github.com/myronmarston/typhoeus.git
- revision: 90fad2aa7e4bce1e730e6e4653c263ad4a1c373e
- branch: vcr_changes
- specs:
- typhoeus (0.1.31)
-
PATH
remote: .
specs:
@@ -89,6 +82,7 @@ GEM
term-ansicolor (1.0.5)
thor (0.14.4)
timecop (0.3.5)
+ typhoeus (0.2.0)
webmock (1.5.0)
addressable (>= 2.2.2)
crack (>= 0.1.7)
@@ -117,6 +111,6 @@ DEPENDENCIES
ruby-debug-base19 (= 0.11.23)
ruby-debug19
timecop (~> 0.3.5)
- typhoeus!
+ typhoeus (~> 0.2.0)
vcr!
webmock (>= 1.5.0)
@@ -6,8 +6,8 @@ module Typhoeus
include VCR::HttpStubbingAdapters::Common
extend self
- MINIMUM_VERSION = '0.1.31'
- MAXIMUM_VERSION = '0.1'
+ MINIMUM_VERSION = '0.2.0'
+ MAXIMUM_VERSION = '0.2'
def http_connections_allowed=(value)
::Typhoeus::Hydra.allow_net_connect = value
@@ -11,9 +11,9 @@
it_behaves_like 'an http stubbing adapter', ['typhoeus'], [:method, :uri, :host, :path, :body, :headers]
it_performs('version checking',
- :valid => %w[ 0.1.31 0.1.99 ],
- :too_low => %w[ 0.1.0 0.1.30 ],
- :too_high => %w[ 0.2.0 1.0.0 ]
+ :valid => %w[ 0.2.0 0.2.99 ],
+ :too_low => %w[ 0.1.0 0.1.31 ],
+ :too_high => %w[ 0.3.0 1.0.0 ]
) do
disable_warnings
before(:each) { @orig_version = Typhoeus::VERSION }
View
@@ -40,7 +40,8 @@ Gem::Specification.new do |s|
{
'patron' => '~> 0.4.6',
'em-http-request' => '~> 0.2.7',
- 'curb' => '~> 0.7.8'
+ 'curb' => '~> 0.7.8',
+ 'typhoeus' => '~> 0.2.0'
}.each do |lib, version|
s.add_development_dependency lib, version
end unless RUBY_PLATFORM == 'java'

0 comments on commit c0acf8f

Please sign in to comment.