Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Packages

Kai Krueger edited this page · 8 revisions
Clone this wiki locally

Binary distribution

!! PAGE being refactored !!

For your convenience, you may use our binaries rather than building hexabus software on your system yourselfs. Tis will be faster and easier for most users.

We are providing binary packages for on our packages server http://packages.mysmartgrid.de

You may choose between packages out of

  • the master-branch (Release, stable, currently empty)
  • the development-branch (Relase candidates, should be stable)
  • some personal development branches (work in progress, unstable!)

To install these packages via apt-get you have to add the source of our repository via:

  • debian RaspberryPi
cd /etc/apt/sources.list.d && sudo wget http://packages.mysmartgrid.de/raspbian/rel_0.6/mysmartgrid-rel06.list

or

cd /etc/apt/sources.list.d && sudo wget http://packages.mysmartgrid.de/raspbian/rel_0.7/mysmartgrid-rel07.list

or

  • ubuntu 14 LTS (amd64)
cd /etc/apt/sources.list.d && sudo wget http://packages.mysmartgrid.de/ubuntu/rel_0.6/mysmartgrid-rel06.list

or

cd /etc/apt/sources.list.d && sudo wget http://packages.mysmartgrid.de/ubuntu/rel_0.7/mysmartgrid-rel07.list

After having added the package-source-file run:

curl http://packages.mysmartgrid.de/package%40mysmartgrid.de.gpg.key | sudo apt-key add -

apt-get update

For the release 0.6 call

  apt-get upgrade

If you upgrade to release 0.7 call

  aptitude full-upgrade

To Install the latest release call

 apt-get install libmysmartgrid libklio libhexabus hexinfo hexanode-backend hexanode-webfrontend

Beaware that the hexabusprotocol of the releases prior 0.7 and 0.7 are imcompatible. When upgrading to release 0.7 all hexabus device needs also to be upgraded. On the RaspberryPi, the Hexastick needs also to be upgraded with a new firmware (branch fw-usb-stick-workaround for kernel 3.18.xx or later).

Something went wrong with that request. Please try again.