Permalink
Browse files

Pin gem versions.

This prevents e.g. Travis currently installing sass 3.3.0.rc.3 when
installing compass.
  • Loading branch information...
1 parent 66919aa commit dd8aa2b03a7e3867d98e35d2be8f86d1a212cd59 @dracos dracos committed Feb 10, 2014
Showing with 6 additions and 2 deletions.
  1. +3 −1 .travis.yml
  2. +3 −1 conf/post_deploy_actions.bash
View
@@ -19,7 +19,9 @@ env:
install:
- sudo apt-get update -qq
- sudo apt-get install -qq ffmpeg libavcodec-extra-53 iceweasel xvfb yui-compressor
- - gem install compass zurb-foundation
+ - gem install --conservative --no-ri --no-rdoc sass -v 3.2.14
+ - gem install --conservative --no-ri --no-rdoc compass -v 0.12.2
+ - gem install --conservative --no-ri --no-rdoc zurb-foundation -v 4.3.2
- pip install $MODULES
- pip install -r requirements.txt
- sed -r
@@ -25,7 +25,9 @@ find . -name '*.pyc' -delete
export GEM_HOME="../gems"
mkdir -p "$GEM_HOME"
export PATH="$GEM_HOME/bin:$PATH"
-gem install --conservative --no-ri --no-rdoc compass zurb-foundation
+gem install --conservative --no-ri --no-rdoc sass -v 3.2.14
+gem install --conservative --no-ri --no-rdoc compass -v 0.12.2
+gem install --conservative --no-ri --no-rdoc zurb-foundation -v 4.3.2
# gather all the static files in one place
./manage.py collectstatic --noinput

0 comments on commit dd8aa2b

Please sign in to comment.