Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

(node:1116) [DEP0095] DeprecationWarning: timers.enroll() is deprecated. Please use setTimeout instead. #2024

Closed
oeliok opened this issue May 23, 2018 · 5 comments
Labels

Comments

@oeliok
Copy link

@oeliok oeliok commented May 23, 2018

when i use node with version > 9,then they will give the warnning.
(node:1116) [DEP0095] DeprecationWarning: timers.enroll() is deprecated. Please use setTimeout instead.

@dougwilson
Copy link
Member

@dougwilson dougwilson commented May 23, 2018

Duplicate of #2003

@dougwilson dougwilson marked this as a duplicate of #2003 May 23, 2018
@prilosac
Copy link

@prilosac prilosac commented Jun 15, 2018

This was marked as a duplicate of #2003 but that is wrong. #2003 talks about DEP0096, this is DEP0095. I assume that they would have similar resolutions if writing the code yourself, but in this case, its the mysql plugin that's doing this, not anything in my own code, and I would like an answer for this

@dougwilson
Copy link
Member

@dougwilson dougwilson commented Jun 15, 2018

Sorry, I didn't notice the difference in numbers. Reopening and pull request is always welcome. Since I though this was a duplicate on accident (thanks for assuming I wad being malicious instead of trying to consider that I didn't notice they were not the same) I have done no work on this. Please conduct yourself better in the future.

@prilosac
Copy link

@prilosac prilosac commented Jun 15, 2018

I was not intending to be malicious and I apologize that I came off that way. I will look into the code and see if I can find a fix, and will try to come off better in the future, thanks for reopening!

@ximendatie
Copy link

@ximendatie ximendatie commented Mar 27, 2019

I solved that
npm install mysql
above works well,when mysql is @2.16.0

@dougwilson dougwilson added the bug label Oct 11, 2019
@mysqljs mysqljs deleted a comment from Codedecks Oct 11, 2019
@mysqljs mysqljs locked as resolved and limited conversation to collaborators Oct 11, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
Development

No branches or pull requests

4 participants