Skip to content
Permalink
Browse files
💥 update no-unsupported-features/es-builtins
  • Loading branch information
mysticatea committed May 2, 2019
1 parent 5d79f2d commit 02d61cfcc1201550945a477c8fcf95572d7b6fec
@@ -10,7 +10,7 @@ Editor integrations of ESLint would be useful to know it in real-time.

### Supported ECMAScript features

This rule supports ECMAScript 2018 and the features which are arrived at Stage 4 by May 2018.
This rule supports ECMAScript 2019.
See also [TC39 finished proposals](https://github.com/tc39/proposals/blob/master/finished-proposals.md).

### Configured Node.js version range
@@ -37,7 +37,7 @@ If you omit the [engines] field, this rule chooses `>=8.0.0` as the configured N
```json
{
"node/no-unsupported-features/es-builtins": ["error", {
"version": ">=6.0.0",
"version": ">=8.0.0",
"ignores": []
}]
}
@@ -59,6 +59,10 @@ The `"ignores"` option accepts an array of the following strings.

<details>

**ES2019:**

- `"Object.fromEntries"`

**ES2017:**

- `"Atomics"`
@@ -49,6 +49,7 @@ const trackMap = {
},
Object: {
assign: { [READ]: { supported: "4.0.0" } },
fromEntries: { [READ]: { supported: "12.0.0" } },
getOwnPropertySymbols: { [READ]: { supported: "0.12.0" } },
is: { [READ]: { supported: "0.10.0" } },
setPrototypeOf: { [READ]: { supported: "0.12.0" } },

0 comments on commit 02d61cf

Please sign in to comment.