Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Release 0.9.0

  • Loading branch information...
commit fecaf665d2f6a8fb6deff0d726b50d8a0655b32c 1 parent 693584b
@aslakhellesoy aslakhellesoy authored
View
3  Gemfile
@@ -1,4 +1,5 @@
source "http://rubygems.org"
gemspec
-gem 'gherkin', :path => '../gherkin' if File.directory?(File.dirname(__FILE__) + '/../gherkin')
+@dependencies.reject!{|dep| dep.name == 'gherkin'}
+gem 'gherkin', :path => '../gherkin'
View
4 History.txt
@@ -1,6 +1,6 @@
-== In Git (0.9.0)
+== 0.9.0 (2010-09-21)
-Maintenance release for the new release of Gherkin 2.2.0.
+Maintenance release for the new release of Gherkin 2.2.3.
=== Bugfixes
* Compatibility with rspec-2.0.0.beta.19 mocks (Aslak Hellesøy)
View
2  cucumber.gemspec
@@ -24,7 +24,7 @@ for important information about this release. Happy cuking!
}
- s.add_dependency 'gherkin', '~> 2.2.2' unless File.directory?(File.dirname(__FILE__) + '/../gherkin')
+ s.add_dependency 'gherkin', '~> 2.2.2'
s.add_dependency 'term-ansicolor', '~> 1.0.5'
s.add_dependency 'builder', '~> 2.1.2'
s.add_dependency 'diff-lcs', '~> 1.1.2'
View
2  lib/cucumber/cli/profile_loader.rb
@@ -1,3 +1,5 @@
+require 'yaml'
+
module Cucumber
module Cli
View
1  lib/cucumber/platform.rb
@@ -1,6 +1,5 @@
# Detect the platform we're running on so we can tweak behaviour
# in various places.
-require 'yaml'
module Cucumber
unless defined?(Cucumber::VERSION)
View
2  lib/cucumber/wire_support/configuration.rb
@@ -1,3 +1,5 @@
+require 'yaml'
+
module Cucumber
module WireSupport
class Configuration
Please sign in to comment.
Something went wrong with that request. Please try again.