Permalink
Browse files

Merge pull request #80 from p/open-uri-1.9

Require open-uri only on ruby 1.9, since it is not needed on 1.8.
  • Loading branch information...
2 parents 857e023 + e16125d commit 0bdbda4ee7da30a4bbc84a07b02ccfabc4b5e3a5 @nahi committed Feb 15, 2012
Showing with 3 additions and 1 deletion.
  1. +3 −1 lib/httpclient/http.rb
View
@@ -7,7 +7,9 @@
require 'time'
-require 'open-uri' # for encoding
+if defined?(Encoding::ASCII_8BIT)
+ require 'open-uri' # for encoding
+end
# A namespace module for HTTP Message definitions used by HTTPClient.

0 comments on commit 0bdbda4

Please sign in to comment.