Skip to content

@cawka cawka tagged this Feb 25, 2019 · 3 commits to master since this tag

Overview
^^^^^^^^

- The submodules of NFD and ndn-cxx have been upgraded to version 0.6.5.

    In order to retrieve the marked versions of ndn-cxx and NFD, use
    --recursive option to the git clone command or run
    git submodule update --init after clone, pull, or merge.

- Base NS-3 was rebased to version 3.29
- Following changes in NFD and ndn-cxx codebases, the build requirements
  have been upgraded to gcc >= 5.3 or clang >= 3.6, boost >= 1.58,
  openssl >= 1.0.2. This effectively drops support for all versions of
  Ubuntu older than 16.04 that use distribution-provided compilers and
  packages.
- The compilation now uses the C++14 standard.

Improvements and bug fixes
^^^^^^^^^^^^^^^^^^^^^^^^^^

- Update face metric based on simulated p2p link delay (4733)
- Remove and replace the previously deprecated and removed in NS-3.29
  QueueBase::MaxPackets
- Update installation instructions

Deprecation
^^^^^^^^^^^

- ndnSIM 2.7 is the last release that supports the legacy content store
  implementation. The future versions will only include content store
  replacement/placement policies implemented using NFD routines. Please
  refer to the latest version of NFD Developer's Guide for more
  information.
Assets 2
You can’t perform that action at this time.