Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

drivers: only display warning if $VERBOSE

fixes #88.
  • Loading branch information...
commit 94edf2f7c3f90bbe88395a0cfb4a6fbe9036587e 1 parent df86826
@nicksieger nicksieger authored
View
2  jdbc-derby/lib/jdbc/derby.rb
@@ -6,6 +6,6 @@ module Derby
if RUBY_PLATFORM =~ /java/
require "derby-#{Jdbc::Derby::VERSION}.jar"
-else
+elsif $VERBOSE
warn "jdbc-derby is only for use with JRuby"
end
View
2  jdbc-h2/lib/jdbc/h2.rb
@@ -5,6 +5,6 @@ module H2
end
if RUBY_PLATFORM =~ /java/
require "h2-#{Jdbc::H2::VERSION}.jar"
-else
+elsif $VERBOSE
warn "jdbc-h2 is only for use with JRuby"
end
View
2  jdbc-hsqldb/lib/jdbc/hsqldb.rb
@@ -5,6 +5,6 @@ module HSQLDB
end
if RUBY_PLATFORM =~ /java/
require "hsqldb-#{Jdbc::HSQLDB::VERSION}.jar"
-else
+elsif $VERBOSE
warn "jdbc-hsqldb is only for use with JRuby"
end
View
4 jdbc-jtds/lib/jdbc/jtds.rb
@@ -1,10 +1,10 @@
module Jdbc
- module JTDS
+ module JTDS
VERSION = "1.2.5"
end
end
if RUBY_PLATFORM =~ /java/
require "jtds-#{Jdbc::JTDS::VERSION}.jar"
-else
+elsif $VERBOSE
warn "jdbc-jtds is only for use with JRuby"
end
View
2  jdbc-mysql/lib/jdbc/mysql.rb
@@ -5,6 +5,6 @@ module MySQL
end
if RUBY_PLATFORM =~ /java/
require "mysql-connector-java-#{Jdbc::MySQL::VERSION}.jar"
-else
+elsif $VERBOSE
warn "jdbc-mysql is only for use with JRuby"
end
View
2  jdbc-postgres/lib/jdbc/postgres.rb
@@ -20,6 +20,6 @@ def self.jdbc_version
if RUBY_PLATFORM =~ /java/
Jdbc::Postgres::require_driver_jar
-else
+elsif $VERBOSE
warn "jdbc-postgres is only for use with JRuby"
end
View
2  jdbc-sqlite3/lib/jdbc/sqlite3.rb
@@ -5,6 +5,6 @@ module SQLite3
end
if RUBY_PLATFORM =~ /java/
require "sqlite-jdbc-#{Jdbc::SQLite3::VERSION}.jar"
-else
+elsif $VERBOSE
warn "jdbc-SQLite3 is only for use with JRuby"
end
Please sign in to comment.
Something went wrong with that request. Please try again.