Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Hubot crashes with korean on UTF-8 IRC server. #10

Open
dfdgsdfg opened this Issue · 3 comments

3 participants

@dfdgsdfg

2011-12-15T14:32:13+00:00 heroku[app.1]: State changed from starting to up
2011-12-15T14:32:20+00:00 app[app.1]: SeMalBot has joined #minec
2011-12-15T14:32:22+00:00 app[app.1]: From undefined to #minec: ㅇㅇ히로빈....... (if somebody chat in korean, then crush)
2011-12-15T14:32:22+00:00 app[app.1]:
2011-12-15T14:32:22+00:00 app[app.1]: /app/node_modules/hubot-irc/node_modules/irc/lib/irc.js:520
2011-12-15T14:32:22+00:00 app[app.1]: throw err;
2011-12-15T14:32:22+00:00 app[app.1]: ^
2011-12-15T14:32:22+00:00 app[app.1]: TypeError: Cannot call method 'toLowerCase' of undefined
2011-12-15T14:32:22+00:00 app[app.1]: at Robot.userForName (/app/node_modules/hubot/src/robot.coffee:190:24)
2011-12-15T14:32:22+00:00 app[app.1]: at IrcBot.userForName (/app/node_modules/hubot/src/adapter.coffee:48:25)
2011-12-15T14:32:22+00:00 app[app.1]: at Client. (/app/node_modules/hubot-irc/src/irc.coffee:108:21)
2011-12-15T14:32:22+00:00 app[app.1]: at Client.emit (events.js:72:17)
2011-12-15T14:32:22+00:00 app[app.1]: at Client. (/app/node_modules/hubot-irc/node_modules/irc/lib/irc.js:361:22)
2011-12-15T14:32:22+00:00 app[app.1]: at Client.emit (events.js:64:17)
2011-12-15T14:32:22+00:00 app[app.1]: at /app/node_modules/hubot-irc/node_modules/irc/lib/irc.js:517:22
2011-12-15T14:32:22+00:00 app[app.1]: at Array.forEach (native)
2011-12-15T14:32:22+00:00 app[app.1]: at Socket. (/app/node_modules/hubot-irc/node_modules/irc/lib/irc.js:514:15)
2011-12-15T14:32:22+00:00 app[app.1]: at Socket.emit (events.js:64:17)
2011-12-15T14:32:24+00:00 heroku[app.1]: State changed from up to crashed
2011-12-15T14:32:24+00:00 heroku[app.1]: Process exited

@jgable
Collaborator

As soon as we get some of the other merges done here, I'll try to take another look at this.

@outsideris

I think it is related withe this issue.

@jgable
Collaborator

Thanks, looks like an issue with the node-irc module. I'll keep an eye out on that issue and hopefully be able to update the dependency with a fixed version.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.