New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

internal_links check fails #1218

Closed
vesaoikonen opened this Issue Sep 17, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@vesaoikonen

vesaoikonen commented Sep 17, 2017

After nanoc update the internal_links check fails with error
NameError: uninitialized constant Nanoc::Checking::Checks::InternalLinks::CGI
Did you mean? Cri
Nanoc::CLI

Line 56 in internal_links.rb is
path = CGI.unescape(path)
I changed it (back?) to
path = URI.unescape(path)
and then checking seems to work again.

@ddfreyne

This comment has been minimized.

Show comment
Hide comment
@ddfreyne

ddfreyne Sep 18, 2017

Member

There’s a missing require 'cgi' in Nanoc. Fix forthcoming.

(The reason why this wasn’t caught earlier is because the automated tests likely indirectly load cgi.)

Member

ddfreyne commented Sep 18, 2017

There’s a missing require 'cgi' in Nanoc. Fix forthcoming.

(The reason why this wasn’t caught earlier is because the automated tests likely indirectly load cgi.)

@ddfreyne

This comment has been minimized.

Show comment
Hide comment
@ddfreyne

ddfreyne Sep 18, 2017

Member

Fixed by f94503b — unfortunately tricky to test automatically.

Member

ddfreyne commented Sep 18, 2017

Fixed by f94503b — unfortunately tricky to test automatically.

@ddfreyne ddfreyne closed this Sep 18, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment