Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ubuntu 18.04 support? #254

Open
nitinvyas opened this Issue May 29, 2018 · 5 comments

Comments

Projects
None yet
5 participants
@nitinvyas
Copy link

nitinvyas commented May 29, 2018

Blocked after upgrading to Ubuntu 18.04 due to following error:
./ethdcrminer64: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./ethdcrminer64)

When is the latest release happening as discussed in -
https://bitcointalk.org/index.php?topic=1433925.24045;wap2

@kochmap

This comment has been minimized.

Copy link

kochmap commented Jun 3, 2018

My miners are working on 18.04 after installing(apt install) this packages:

  • ocl-icd-opencl-dev
  • libcurl4
  • libcurl3
@december-soul

This comment has been minimized.

Copy link

december-soul commented Jun 5, 2018

libcurl3 will remove libcurl4 :-(

@nitinvyas

This comment has been minimized.

Copy link
Author

nitinvyas commented Jun 7, 2018

I am able to run after installing libcurl3 [apt-get install libcurl3] but getting following error on Vega10 as also mentioned in issue #29

Tried with enabling & disabling the GPU_FORCE_64BIT_PTR to 1 & 0
Running on Radeon RX Vega + Ubuntu 18.04 LTS

▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒ͻ
▒ Claymore's Dual ETH + DCR/SC/LBC/PASC GPU Miner v10.0 ▒
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒ͼ

At least 16 GB of Virtual Memory is required for multi-GPU systems
Make sure you defined GPU_MAX_ALLOC_PERCENT 100
Be careful with overclocking, use default clocks for first tests
Press "s" for current statistics, "0".."9" to turn on/off cards, "r" to reload pools, "e" or "d" to select current pool
OpenCL initializing...

AMD Cards available: 1
GPU #0: gfx900, 16192 MB available, 64 compute units
GPU #0 recognized as Vega
POOL/SOLO version
Cannot build OpenCL program for GPU 0
GPU #0: algorithm ASM
No NVIDIA CUDA GPUs detected.
Total cards: 1
AMD ADL library not found.

BENCHMARK MODE!

Setting DAG epoch #136...
ETH - Total Speed: 0.000 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:00
ETH: GPU0 0.000 Mh/s
Setting DAG epoch #136 for GPU0
Create GPU buffer for GPU0
GPU0, OpenCL error -48 (0) - cannot create DAG on GPU
ETH - Total Speed: 0.000 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:00
ETH: GPU0 0.000 Mh/s
GPU 0 failed
Setting DAG epoch #136 for GPU0

@Jorropo

This comment has been minimized.

Copy link

Jorropo commented Sep 1, 2018

I have the same problem

@stone212

This comment has been minimized.

Copy link

stone212 commented Dec 7, 2018

@nitinvyas @Jorropo Have you tried Claymore 11.8? I did not have this problem with 11.8 on a fresh Ubuntu 18.04 install. If the upgrade works you can close the issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.