New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Navigation] Default route should not depend on 'mine' root #401

Closed
larkin opened this Issue Dec 9, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@larkin
Member

larkin commented Dec 9, 2015

When operating without a mine root, the application loads and navigates to the hidden root container object. Nothing appears selected, and pressing the create button results in a broken locator component.

Once an object has been selected in the tree, everything functions as it normally would, so it's not a blocking bug, just an annoying bug.

The default route should be determined at run time to be an object that exists, with some ability to be overridden by bundle.

Here's a screenshot of what currently occurs:

broken root

@larkin larkin added the bug label Dec 9, 2015

@larkin larkin added this to the Bradbury milestone Dec 9, 2015

@VWoeltjen VWoeltjen self-assigned this Dec 11, 2015

@VWoeltjen VWoeltjen modified the milestones: Bradbury, Clarke Jan 26, 2016

@VWoeltjen VWoeltjen modified the milestones: Clarke, Ellison Feb 23, 2016

larkin added a commit that referenced this issue Mar 1, 2016

@larkin

This comment has been minimized.

Show comment
Hide comment
@larkin

larkin Mar 1, 2016

Member

Closed via #416.

Member

larkin commented Mar 1, 2016

Closed via #416.

@larkin larkin closed this Mar 1, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment