Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

connect-gzip doesn't work with connect >= 2.3.7 #17

Open
papandreou opened this Issue Jul 17, 2012 · 1 comment

Comments

Projects
None yet
1 participant
Contributor

papandreou commented Jul 17, 2012

In connect 2.3.7 the send function was split into a separate module (senchalabs/connect@3ea7fa2), which breaks connect-gzip. This is unfortunate because connect-gzip specifies a very liberal version range in package.json, so all fresh installs of connect-gzip are broken right now.

My recommendation is to pin the connect dependency at a specific version:

   "dependencies": {
-    "connect": ">=1 <2",
+    "connect": "=2.3.6",
     "mime": ">=0.0.1"
   },

... then release a new version of connect-gzip asap.

Then later when we're ready to use the new connect API, we can pin it at whatever is the latest version at that point. It's a little more housekeeping, but much safer.

And yes, this just bit me upon upgrading a production server :/

Contributor

papandreou commented Aug 29, 2012

@nateps Ping? This is pretty serious. As I said, all installs of connect-gzip are presently broken.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment