Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

bump guava.

  • Loading branch information...
commit 2c5b07c96fadd4006805f48c08aa5b6e72ab1110 1 parent 74edb8f
Sam Ritchie authored
Showing with 19 additions and 19 deletions.
  1. +1 −0  .gitignore
  2. +2 −1  .travis.yml
  3. +2 −2 README.md
  4. +14 −16 project.clj
View
1  .gitignore
@@ -15,3 +15,4 @@ lib/
profiles.xml
.lein-deps-sum
build
+target
View
3  .travis.yml
@@ -7,7 +7,8 @@
# http://about.travis-ci.org/docs/user/build-configuration/
language: clojure
-script: lein javac, junit
+lein: lein2
+script: lein2 test
branches:
only:
- develop
View
4 README.md
@@ -7,11 +7,11 @@ A dramatically simpler and more powerful way to store records on a distributed f
to include dfs-datastores in your project, add the following to project.clj:
```clojure
-[backtype/dfs-datastores "1.1.2"]
+[backtype/dfs-datastores "1.2.0"]
```
To run the tests:
```clojure
-lein deps, javac, junit
+lein junit
```
View
30 project.clj
@@ -1,18 +1,16 @@
-(defproject backtype/dfs-datastores "1.1.4-SNAPSHOT"
- :source-path "src/clj"
- :test-path "test/clj"
- :java-source-path "src/jvm"
- :java-test-path "test/jvm"
- :javac-options {:debug "true" :fork "true"}
- :javac-source-path [["src"] ["test"]]
- :junit [["classes"]]
+(defproject backtype/dfs-datastores "1.2.0-SNAPSHOT"
+ :min-lein-version "2.0.0"
+ :source-paths ["src/clj"]
+ :test-paths ["test/clj"]
+ :java-source-paths ["src/jvm" "test/jvm"]
+ :hooks [leiningen.hooks.junit]
+ :junit ["test/jvm"]
:junit-options {:fork "off" :haltonfailure "on"}
:dependencies [[jvyaml "1.0.0"]
- [com.google.guava/guava "r09"]]
- :dev-dependencies [[org.apache.hadoop/hadoop-core "0.20.2-dev"]
- [midje "1.3.0" :exclusions [org.clore/clojure]]
- [org.clojure/clojure "1.2.1"]
- [lein-midje "1.0.8"]
- [lein-javac "1.3.0"]
- [lein-junit "1.0.0"]
- [junit "4.7"]])
+ [com.google.guava/guava "13.0"]]
+ :plugins [[lein-midje "1.0.10"]
+ [lein-junit "1.0.3"]]
+ :profiles {:dev {:dependencies [[junit "4.10"]
+ [org.apache.hadoop/hadoop-core "0.20.2-dev"]
+ [midje "1.4.0" :exclusions [org.clojure/clojure]]
+ [org.clojure/clojure "1.4.0"]]}})
Please sign in to comment.
Something went wrong with that request. Please try again.