Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Release 1.1.0!

  • Loading branch information...
commit 0577148bd22a9b8db8227500dee9c90e3627f60f 1 parent e4e4ff5
@technomancy technomancy authored
Showing with 7 additions and 7 deletions.
  1. +1 −1  NEWS
  2. +3 −3 bin/lein
  3. +1 −1  bin/lein.bat
  4. +2 −2 project.clj
View
2  NEWS
@@ -1,6 +1,6 @@
Leiningen NEWS -- history of user-visible changes
-= 1.1.0 / ???
+= 1.1.0 / 2010-02-16
* Added "lein upgrade" task
View
6 bin/lein
@@ -1,6 +1,6 @@
#!/bin/bash
-VERSION="1.1.0-SNAPSHOT"
+VERSION="1.1.0"
CLASSPATH="$(find lib/ -follow -mindepth 1 -maxdepth 1 -print0 2> /dev/null | tr \\0 \:)"
LEIN_JAR="$HOME/.m2/repository/leiningen/leiningen/$VERSION/leiningen-$VERSION-standalone.jar"
@@ -60,7 +60,7 @@ done
HTTP_CLIENT="wget -O"
if type -p curl >/dev/null 2>&1; then
- HTTP_CLIENT="curl -o"
+ HTTP_CLIENT="curl -L -o"
fi
if [ "$1" = "repl" ]; then
@@ -80,7 +80,7 @@ elif [ "$1" = "self-install" ]; then
fi
echo "Downloading Leiningen now..."
mkdir -p `dirname "$LEIN_JAR"`
- LEIN_URL="http://repo.technomancy.us/leiningen-$VERSION-standalone.jar"
+ LEIN_URL="http://github.com/downloads/technomancy/leiningen/leiningen-$VERSION-standalone.jar"
exec $HTTP_CLIENT "$LEIN_JAR" "$LEIN_URL"
elif [ "$1" = "upgrade" ]; then
if [[ $VERSION == *SNAPSHOT ]]; then
View
2  bin/lein.bat
@@ -8,7 +8,7 @@ rem and it should be copied on %CLOJURE_JAR% path
set CLOJURE_VERSION=1.1.0
-set LEIN_VERSION=1.1.0-SNAPSHOT
+set LEIN_VERSION=1.1.0
rem uncomment this and set paths explicitly
rem set LEIN_JAR=C:\Documents and Settings\wojcirob\.m2\repository\leiningen\leiningen\%LEIN_VERSION%\leiningen-%LEIN_VERSION%-standalone.jar
View
4 project.clj
@@ -2,11 +2,11 @@
;; defproject form. It can have other code in it as well, including
;; loading other task definitions.
-(defproject leiningen "1.1.0-RC2"
+(defproject leiningen "1.1.0"
:description "A build tool designed not to set your hair on fire."
:url "http://github.com/technomancy/leiningen"
:dependencies [[org.clojure/clojure "1.1.0"]
- [org.clojure/clojure-contrib "1.1.0-master-SNAPSHOT"]
+ [org.clojure/clojure-contrib "1.1.0"]
[ant/ant "1.6.5"]
[ant/ant-launcher "1.6.5"]
[jline "0.9.94"]
Please sign in to comment.
Something went wrong with that request. Please try again.